summaryrefslogtreecommitdiffstats
path: root/package/bash
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-01-19 13:22:08 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-01-20 09:06:00 +0100
commitb367ca32e53a774c174899e44c77ed1d128cbcdc (patch)
tree66eb2b9ac2eb2b578827824a73ee4cdbfbd184b3 /package/bash
parent95632704cd966b32c3391aa732eaad10d24fe0fb (diff)
downloadbuildroot-novena-b367ca32e53a774c174899e44c77ed1d128cbcdc.tar.gz
buildroot-novena-b367ca32e53a774c174899e44c77ed1d128cbcdc.zip
bash: Adding features that can not be automatically detected while cross-compiling
There are some bash features that can not be detected automatically during configure stage while cross-compiling. This commit forces them on. Signed-off-by: Arkady Gilinsky <arcadyg@gmail.com> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index f1f951c3a..44f933775 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -7,7 +7,11 @@
BASH_VERSION = 4.2
BASH_SITE = $(BR2_GNU_MIRROR)/bash
BASH_DEPENDENCIES = ncurses
-BASH_CONF_ENV = bash_cv_job_control_missing=no
+BASH_CONF_ENV += \
+ bash_cv_job_control_missing=present \
+ bash_cv_sys_named_pipes=present \
+ bash_cv_func_sigsetjmp=present \
+ bash_cv_printf_a_format=yes
# Make sure we build after busybox so that /bin/sh links to bash
ifeq ($(BR2_PACKAGE_BUSYBOX),y)