summaryrefslogtreecommitdiffstats
path: root/package/bash
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2005-04-23 17:45:18 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2005-04-23 17:45:18 +0000
commit9b82915de4f091517376a828bf9f4e72038e5b12 (patch)
treeea2cbff91f9658420365e624bec3dd67ac0f4850 /package/bash
parent7f6a277243273f0be7e9445444fa4f2ba771f9a7 (diff)
downloadbuildroot-novena-9b82915de4f091517376a828bf9f4e72038e5b12.tar.gz
buildroot-novena-9b82915de4f091517376a828bf9f4e72038e5b12.zip
Fix install error caused by 'ln -sf' which tries to use the target's
'ln' instead of the host. A quick grep through the other packages shows that this may be an issue as well. I will probably have more fixes later today.
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index d25b1558e..dd1417977 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -59,7 +59,7 @@ $(TARGET_DIR)/$(BASH_TARGET_BINARY): $(BASH_DIR)/$(BASH_BINARY)
$(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(BASH_DIR) install
rm -f $(TARGET_DIR)/bin/bash*
mv $(TARGET_DIR)/usr/bin/bash* $(TARGET_DIR)/bin/
- (cd $(TARGET_DIR)/bin; ln -fs bash sh)
+ (cd $(TARGET_DIR)/bin; /bin/ln -fs bash sh)
rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc