summaryrefslogtreecommitdiffstats
path: root/package/bash
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/bash
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index ccb28f18c..cd531f69a 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -28,7 +28,7 @@ $(BASH_DIR)/.unpacked: $(DL_DIR)/$(BASH_SOURCE)
$(BASH_DIR)/.configured: $(BASH_DIR)/.unpacked
# bash_cv_have_mbstate_t=yes
(cd $(BASH_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) CC_FOR_BUILD="$(HOSTCC)" \
+ $(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
ac_cv_func_setvbuf_reversed=no \
./configure \
@@ -39,6 +39,7 @@ $(BASH_DIR)/.configured: $(BASH_DIR)/.unpacked
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
+ --libdir=/lib \
--libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \