summaryrefslogtreecommitdiffstats
path: root/package/bash
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-19 14:31:15 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-19 14:31:15 +0000
commit134f256d2ffa2412986d78a2d2885e10147dda2b (patch)
treea5f78466d7afa7c14862c35282875ca8dfd8a704 /package/bash
parentdfd5b4d38fbe6bba2fd824a8a3709f1cf0586404 (diff)
downloadbuildroot-novena-134f256d2ffa2412986d78a2d2885e10147dda2b.tar.gz
buildroot-novena-134f256d2ffa2412986d78a2d2885e10147dda2b.zip
convert patches to -p1 format
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash.mk2
-rw-r--r--package/bash/bash30-00153
-rw-r--r--package/bash/bash30-00230
-rw-r--r--package/bash/bash30-00333
-rw-r--r--package/bash/bash30-00429
-rw-r--r--package/bash/bash30-00529
-rw-r--r--package/bash/bash30-00628
-rw-r--r--package/bash/bash30-00745
-rw-r--r--package/bash/bash30-00832
-rw-r--r--package/bash/bash30-00937
-rw-r--r--package/bash/bash30-01029
-rw-r--r--package/bash/bash30-01140
-rw-r--r--package/bash/bash30-01226
-rw-r--r--package/bash/bash30-01325
14 files changed, 71 insertions, 367 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index e0f5638cd..704b45b73 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -18,7 +18,7 @@ bash-source: $(DL_DIR)/$(BASH_SOURCE)
$(BASH_DIR)/.unpacked: $(DL_DIR)/$(BASH_SOURCE)
$(BASH_CAT) $(DL_DIR)/$(BASH_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- patch_level=-p0 toolchain/patch-kernel.sh $(BASH_DIR) package/bash/ bash??-???
+ toolchain/patch-kernel.sh $(BASH_DIR) package/bash/ bash??-???
# This is broken when -lintl is added to LIBS
$(SED) 's,LIBS_FOR_BUILD =.*,LIBS_FOR_BUILD =,g' \
$(BASH_DIR)/builtins/Makefile.in
diff --git a/package/bash/bash30-001 b/package/bash/bash30-001
index 9e5ae682a..f2e377d89 100644
--- a/package/bash/bash30-001
+++ b/package/bash/bash30-001
@@ -1,30 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-001
-
-Bug-Reported-by: Karlheinz Nolte <kn@k-nolte.de>
-Bug-Reference-ID: <20040801200058.GA3311@mars.home.k-nolte.de>
-Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2004-08/msg00009.html
-
-Bug-Description:
-
- The following script triggers the segfault.
- This was found by Costa Tsaousis the author of FireHOL.
- He wrotes:
-
- "I think I have found the bug. The script bellow crashes at the
- third echo (UNSET). It seems to be a problem of the "unset" BASH
- function when erasing arrays. It leaves something behind so that if
- the array just unset is referenced, it produces a segmentation fault.
- According to the documentation the first and the third expansions
- should be exactly the same."
-
-Patch:
-
-*** ../bash-3.0/arrayfunc.c Fri Dec 19 00:03:09 2003
---- arrayfunc.c Sun Aug 1 20:43:00 2004
+*** bash-3.0/arrayfunc.c Fri Dec 19 00:03:09 2003
+--- bash/arrayfunc.c Sun Aug 1 20:43:00 2004
***************
*** 612,616 ****
@@ -39,8 +14,8 @@ Patch:
}
-*** ../bash-3.0/subst.c Sun Jul 4 13:56:13 2004
---- subst.c Thu Aug 12 13:36:17 2004
+*** bash-3.0/subst.c Sun Jul 4 13:56:13 2004
+--- bash/subst.c Thu Aug 12 13:36:17 2004
***************
*** 4983,4987 ****
return -1;
@@ -55,8 +30,8 @@ Patch:
{
vtype = VT_ARRAYMEMBER;
-*** ../bash-3.0/variables.c Sun Jul 4 13:57:26 2004
---- variables.c Wed Aug 4 15:28:04 2004
+*** bash-3.0/variables.c Sun Jul 4 13:57:26 2004
+--- bash/variables.c Wed Aug 4 15:28:04 2004
***************
*** 1420,1428 ****
@@ -94,8 +69,8 @@ Patch:
! }
was_tmpvar = old_var && tempvar_p (old_var);
-*** ../bash-3.0/pcomplete.c Thu Jan 8 10:36:17 2004
---- pcomplete.c Tue Aug 3 23:15:41 2004
+*** bash-3.0/pcomplete.c Thu Jan 8 10:36:17 2004
+--- bash/pcomplete.c Tue Aug 3 23:15:41 2004
***************
*** 864,867 ****
--- 864,869 ----
@@ -114,8 +89,8 @@ Patch:
+ VUNSETATTR (v, att_invisible);
a = array_cell (v);
-*** ../bash-3.0/array.c Thu May 6 08:24:13 2004
---- array.c Wed Aug 25 15:50:42 2004
+*** bash-3.0/array.c Thu May 6 08:24:13 2004
+--- bash/array.c Wed Aug 25 15:50:42 2004
***************
*** 452,456 ****
array_dispose_element(new);
@@ -130,8 +105,8 @@ Patch:
return(0);
} else if (element_index(ae) > i) {
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
@@ -145,8 +120,8 @@ Patch:
! #define PATCHLEVEL 1
#endif /* _PATCHLEVEL_H_ */
-*** ../bash-3.0/tests/dbg-support.tests Tue Mar 25 15:33:03 2003
---- tests/dbg-support.tests Tue Aug 3 23:09:29 2004
+*** bash-3.0/tests/dbg-support.tests Tue Mar 25 15:33:03 2003
+--- bash/tests/dbg-support.tests Tue Aug 3 23:09:29 2004
***************
*** 63,68 ****
trap 'print_return_trap $LINENO' RETURN
diff --git a/package/bash/bash30-002 b/package/bash/bash30-002
index 57ba938c8..fa0b8ddde 100644
--- a/package/bash/bash30-002
+++ b/package/bash/bash30-002
@@ -1,27 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-002
-
-Bug-Reported-by: "Ralf S. Engelschall" <rse@engelschall.com>
-Bug-Reference-ID: <20040728082038.GA31398@engelschall.com>
-Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2004-07/msg00262.html
-
-Bug-Description:
-
-After upgrading the OpenPKG "bash" package to 3.0, we had to discover
-that the prompt handling on Bash 3.0 / Readline 5.0 is broken if a
-multiline prompt (a string containing newlines) is used. The effect is
-that on the first input line (where the last line of the prompt is the
-prefix) the input line is wrapped N characters before the last column
-where N seems to be exactly the length (including newlines) of the
-prompt ($PS1) minus the characters on the last line of the prompt.
-
-Patch:
-
-*** ../bash-3.0/lib/readline/display.c Thu May 27 22:57:51 2004
---- lib/readline/display.c Wed Jul 28 13:48:04 2004
+*** bash-3.0/lib/readline/display.c Thu May 27 22:57:51 2004
+--- bash/lib/readline/display.c Wed Jul 28 13:48:04 2004
***************
*** 352,356 ****
&prompt_last_invisible,
@@ -49,8 +27,8 @@ Patch:
*t = c;
return (prompt_prefix_length);
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash30-003 b/package/bash/bash30-003
index 4a90df9c4..349b796ce 100644
--- a/package/bash/bash30-003
+++ b/package/bash/bash30-003
@@ -1,22 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-003
-
-Bug-Reported-by: Egmont Koblinger <egmont@uhulinux.hu>
-Bug-Reference-ID: <Pine.LNX.4.58L0.0407290044500.12603@sziami.cs.bme.hu>
-Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2004-07/msg00279.html
-
-Bug-Description:
-
-Bash no longer accepts the `trap signum' syntax when in POSIX mode. This
-patch restores a measure of backwards compatibility.
-
-Patch:
-
-*** ../bash-3.0/builtins/trap.def Thu May 27 22:26:19 2004
---- builtins/trap.def Thu Aug 5 08:55:43 2004
+*** bash-3.0/builtins/trap.def Thu May 27 22:26:19 2004
+--- bash/builtins/trap.def Thu Aug 5 08:55:43 2004
***************
*** 24,28 ****
$BUILTIN trap
@@ -75,8 +58,8 @@ Patch:
! else if (posixly_correct == 0 && first_arg && *first_arg &&
(*first_arg != '-' || first_arg[1]) &&
signal_object_p (first_arg, opt) && list->next == 0)
-*** ../bash-3.0/doc/bashref.texi Sat Jun 26 14:26:07 2004
---- doc/bashref.texi Fri Aug 27 12:33:46 2004
+*** bash-3.0/doc/bashref.texi Sat Jun 26 14:26:07 2004
+--- bash/doc/bashref.texi Fri Aug 27 12:33:46 2004
***************
*** 5954,5958 ****
The @code{trap} builtin doesn't check the first argument for a possible
@@ -92,8 +75,8 @@ Patch:
signal to the original disposition, they should use @samp{-} as the
first argument.
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
@@ -107,8 +90,8 @@ Patch:
! #define PATCHLEVEL 3
#endif /* _PATCHLEVEL_H_ */
-*** ../bash-3.0/tests/errors.right Thu May 27 22:26:03 2004
---- tests/errors.right Sat Aug 7 22:35:10 2004
+*** bash-3.0/tests/errors.right Thu May 27 22:26:03 2004
+--- bash/tests/errors.right Sat Aug 7 22:35:10 2004
***************
*** 86,90 ****
./errors.tests: line 216: trap: NOSIG: invalid signal specification
diff --git a/package/bash/bash30-004 b/package/bash/bash30-004
index b18e54c58..7fda2e9f2 100644
--- a/package/bash/bash30-004
+++ b/package/bash/bash30-004
@@ -1,22 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-004
-
-Bug-Reported-by: Stephane Chazelas <stephane_chazelas@yahoo.fr>
-Bug-Reference-ID: <20040902131957.GC1860@frhdtmp102861.morse.corp.wan>
-Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2004-07/msg00291.html
-
-Bug-Description:
-
-Calculation of lengths and offsets for parameter string length and substring
-expansion does not correctly account for multibyte characters.
-
-Patch:
-
- *** ../bash-3.0/subst.c Sun Jul 4 13:56:13 2004
---- subst.c Thu Aug 12 13:36:17 2004
+*** bash-3.0/subst.c Sun Jul 4 13:56:13 2004
+--- bash/subst.c Thu Aug 12 13:36:17 2004
***************
*** 4692,4695 ****
--- 4692,4715 ----
@@ -97,8 +80,8 @@ Patch:
! len = MB_STRLEN (value);
break;
case VT_POSPARMS:
-*** ../bash-3.0/include/shmbutil.h Mon Apr 19 09:59:42 2004
---- include/shmbutil.h Thu Sep 2 15:20:47 2004
+*** bash-3.0/include/shmbutil.h Mon Apr 19 09:59:42 2004
+--- bash/include/shmbutil.h Thu Sep 2 15:20:47 2004
***************
*** 32,35 ****
--- 32,37 ----
@@ -128,8 +111,8 @@ Patch:
#endif /* !HANDLE_MULTIBYTE */
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash30-005 b/package/bash/bash30-005
index 3d355a7ba..9c73db1ed 100644
--- a/package/bash/bash30-005
+++ b/package/bash/bash30-005
@@ -1,22 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-005
-
-Bug-Reported-by: schwab@suse.de
-Bug-Reference-ID: <20040801085535.E83D41DB3FFE9@sykes.suse.de>
-Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2004-08/msg00004.html
-
-Bug-Description:
-
-Moving upwards in the history (with previous-history) and back again
-clobbers the last history line.
-
-Patch:
-
-*** ../bash-3.0/lib/readline/misc.c Wed Jul 7 08:56:32 2004
---- lib/readline/misc.c Sat Aug 7 22:38:53 2004
+*** bash-3.0/lib/readline/misc.c Wed Jul 7 08:56:32 2004
+--- bash/lib/readline/misc.c Sat Aug 7 22:38:53 2004
***************
*** 277,286 ****
_rl_saved_line_for_history->data = (char *)rl_undo_list;
@@ -30,8 +13,8 @@ Patch:
return 0;
--- 277,280 ----
-*** ../bash-3.0/lib/readline/vi_mode.c Tue Jul 13 14:08:27 2004
---- lib/readline/vi_mode.c Tue Aug 17 00:12:09 2004
+*** bash-3.0/lib/readline/vi_mode.c Tue Jul 13 14:08:27 2004
+--- bash/lib/readline/vi_mode.c Tue Aug 17 00:12:09 2004
***************
*** 273,280 ****
--- 273,282 ----
@@ -46,8 +29,8 @@ Patch:
rl_noninc_reverse_search (count, key);
break;
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash30-006 b/package/bash/bash30-006
index fccc33b20..b43cfff9d 100644
--- a/package/bash/bash30-006
+++ b/package/bash/bash30-006
@@ -1,25 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-006
-
-Bug-Reported-by: alexander@skwar.name
- Tomohiro KUBOTA <debian@tmail.plala.or.jp>
-Bug-Reference-ID: <20040801124721.C69B8A2547A@server.bei.digitalprojects.com>
- <16688.41450.433668.480445@gargle.gargle.HOWL>
-Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2004-08/msg00006.html
- http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=257540
-
-Bug-Description:
-
-Prompts with multibyte characters or invisible characters following a line
-wrap are displayed incorrectly.
-
-Patch:
-
-*** ../bash-3.0/lib/readline/display.c Thu May 27 22:57:51 2004
---- lib/readline/display.c Mon Aug 30 11:55:02 2004
+*** bash-3.0/lib/readline/display.c Thu May 27 22:57:51 2004
+--- bash/lib/readline/display.c Mon Aug 30 11:55:02 2004
***************
*** 202,206 ****
{
@@ -148,8 +128,8 @@ Patch:
}
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash30-007 b/package/bash/bash30-007
index b4abb9be3..899e83aa5 100644
--- a/package/bash/bash30-007
+++ b/package/bash/bash30-007
@@ -1,42 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-007
-
-Bug-Reported-by: Oliver Kiddle <okiddle@yahoo.co.uk>
- Tim Waugh <twaugh@redhat.com>
-Bug-Reference-ID: <10454.1091313247@athlon>
- <20040804100140.GX8175@redhat.com>
-Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2004-07/msg00313.html
- http://lists.gnu.org/archive/html/bug-bash/2004-08/msg00056.html
-
-Bug-Description:
-
-Two bugs:
-
-How does it decide what characters are allowed. The following really
-looks like a bug to me:
-$ echo {<C4>..D}
-That's accepted and produces output that seems to wrap round to ^A and
-then goes up to D. Note that I'm using an ISO-8859-1 locale. If that
-works at all, it should surely descend.
-
-This short script:
-
-var=baz
-echo foo{bar,${var}.}
-echo foo{bar,${var}}
-
-gives the following output with bash-3.0:
-
-./test: line 2: foo${var.}: bad substitution
-foobar} foobaz
-
-Patch:
-
-*** ../bash-3.0/braces.c Thu Dec 4 11:09:52 2003
---- braces.c Wed Aug 4 14:34:33 2004
+*** bash-3.0/braces.c Thu Dec 4 11:09:52 2003
+--- bash/braces.c Wed Aug 4 14:34:33 2004
***************
*** 341,346 ****
if (lhs_t == ST_CHAR)
@@ -61,8 +24,8 @@ Patch:
continue;
}
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash30-008 b/package/bash/bash30-008
index 57c2c6a45..6d06a849a 100644
--- a/package/bash/bash30-008
+++ b/package/bash/bash30-008
@@ -1,29 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-008
-
-Bug-Reported-by: uberlord@rsm.demon.co.uk
-Bug-Reference-ID: <1092327965.4233.1.camel@uberlaptop.ubernet>
-Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2004-08/msg00144.html
-
-Bug-Description:
-
-> Description:
-> Bash 3 breaks array expansion
->
-> Repeat-By:
-> #!/bin/bash
-> x=(one two)
-> echo ${x[@]:1}
-> # prints nothing in bash 3
-> # prints two in bash 2
-
-Patch:
-
-*** ../bash-3.0/subst.c Sun Jul 4 13:56:13 2004
---- subst.c Thu Aug 12 13:36:17 2004
+*** bash-3.0/subst.c Sun Jul 4 13:56:13 2004
+--- bash/subst.c Thu Aug 12 13:36:17 2004
***************
*** 4892,4896 ****
*e1p += len;
@@ -38,8 +14,8 @@ Patch:
return (-1);
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash30-009 b/package/bash/bash30-009
index 5c1bfd11f..1fcc7c552 100644
--- a/package/bash/bash30-009
+++ b/package/bash/bash30-009
@@ -1,34 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-009
-
-Bug-Reported-by: Tim Waugh <twaugh@redhat.com>
-Bug-Reference-ID: <20040810083805.GT2177@redhat.com>
-Bug-Reference-URL: https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=129526b
- http://lists.gnu.org/archive/html/bug-bash/2004-08/msg00116.html
-
-Bug-Description:
-
--->
-Steps to Reproduce:
-1. Launch a bash shell
-2. Set editing mode to 'vi' with 'set -o vi'
-3. Type any command, but don't hit return
-4. Enter vi-command mode by hitting the escape key
-5. Go to the end of line with the '$' command
-6. Type 'r' to change the last character
-7. Type any character (other than what the character already is)
-
-The last two characters are inexplicably swapped
-after the last character is changed.
-<--
-
-Patch:
-
-*** ../bash-3.0/lib/readline/vi_mode.c Tue Jul 13 14:08:27 2004
---- lib/readline/vi_mode.c Tue Aug 17 00:12:09 2004
+*** bash-3.0/lib/readline/vi_mode.c Tue Jul 13 14:08:27 2004
+--- bash/lib/readline/vi_mode.c Tue Aug 17 00:12:09 2004
***************
*** 691,695 ****
wchar_t wc;
@@ -94,8 +65,8 @@ Patch:
else
#endif
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash30-010 b/package/bash/bash30-010
index 0885fe154..3de5a582a 100644
--- a/package/bash/bash30-010
+++ b/package/bash/bash30-010
@@ -1,26 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-010
-
-Bug-Reported-by: Samuel Thibault <samuel.thibault@ens-lyon.org>
-Bug-Reference-ID: <E1Bo8Sq-0004u5-00@bouh>
-Bug-Reference-URL: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=261142
-
-Bug-Description:
-
-When trying to auto-complete ~/../``/, I just get:
-malloc: bashline.c:1340: assertion botched
-free: start and end chunk sizes differ
-last command: kill -9 %2
-Stopping myself...
-
-
-Patch:
-
-*** ../bash-3.0/bashline.c Mon Jul 5 23:22:12 2004
---- bashline.c Thu Sep 2 16:00:12 2004
+*** bash-3.0/bashline.c Mon Jul 5 23:22:12 2004
+--- bash/bashline.c Thu Sep 2 16:00:12 2004
***************
*** 101,104 ****
--- 101,105 ----
@@ -99,8 +78,8 @@ Patch:
/* Handle symbolic link references and other directory name
expansions while hacking completion. */
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash30-011 b/package/bash/bash30-011
index 94937b7b4..2c77f115b 100644
--- a/package/bash/bash30-011
+++ b/package/bash/bash30-011
@@ -1,37 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-011
-
-Bug-Reported-by: Egmont Koblinger <egmont@uhulinux.hu>
-Bug-Reference-ID: <Pine.LNX.4.58L0.0407282151140.8088@sziami.cs.bme.hu>
-Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2004-07/msg00277.html
-
-Bug-Description:
-
-I've just upgraded to readline 5.0 and bash 3.0 and tried them with UTF-8
-encoding. I found line editing to be quite buggy:
-
-I type an accented letter, let's say <E1>. Then <E1> appears. I press the left
-arrow, the cursor goes back, it is now over <E1>. I press <E9>. Now <E9><E1> is
-visible, which is correct, but the cursor is past the two letters, though
-it should be over <E1>. Here only the first Left arrow takes affect, moves
-the cursor over <E1>, but the 2nd time I press Left, it just beeps, doesn't
-move to the first char (<E9>). Now a Right arrow doesn't move the cursor, but
-causes further Left and Right arrows to work as expected. To go on,
-similar bug occurs nearly every time that I insert an accented letter
-before or amongs other ones (but not at the end of the line). When the
-command line has about ten or twenty accented letters (and no or hardly
-any non-accented ones), line editing becomes a total chaos, where
-sometimes inserting another accented letter causes the cursor to jump many
-characters to the right, and pressing the Left arrow sometimes causes the
-cursor to jump back lots of characters at once.
-
-Patch:
-
-*** ../bash-3.0/lib/readline/mbutil.c Wed Jan 14 09:44:52 2004
---- lib/readline/mbutil.c Wed Aug 18 22:25:57 2004
+*** bash-3.0/lib/readline/mbutil.c Wed Jan 14 09:44:52 2004
+--- bash/lib/readline/mbutil.c Wed Aug 18 22:25:57 2004
***************
*** 127,135 ****
{
@@ -54,8 +22,8 @@ Patch:
break;
}
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash30-012 b/package/bash/bash30-012
index 60500d2e3..221f1b415 100644
--- a/package/bash/bash30-012
+++ b/package/bash/bash30-012
@@ -1,23 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-012
-
-Bug-Reported-by: ben@ncipher.com
-Bug-Reference-ID: <E1BxQYe-0002p1-00@berdoo.ncipher.com>
-Bug-Reference-URL: http://lists.gnu.org/archive/html/bug-bash/2004-08/msg00215.html
-
-Bug-Description:
-
-When using the pipefail option, the following command:
- echo foo | false
-produces an exit status of 0, ignoring the exit status of false.
-
-Patch:
-
-*** ../bash-3.0/jobs.c Fri Apr 23 16:28:25 2004
---- jobs.c Wed Aug 18 11:15:07 2004
+*** bash-3.0/jobs.c Fri Apr 23 16:28:25 2004
+--- bash/jobs.c Wed Aug 18 11:15:07 2004
***************
*** 1779,1784 ****
{
@@ -39,8 +21,8 @@ Patch:
return fail;
}
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash30-013 b/package/bash/bash30-013
index a29b404d6..feee1ef44 100644
--- a/package/bash/bash30-013
+++ b/package/bash/bash30-013
@@ -1,22 +1,5 @@
- BASH PATCH REPORT
- =================
-
-Bash-Release: 3.0
-Patch-ID: bash30-013
-
-Bug-Reported-by: Len Lattanzi <llattanzi@apple.com>
-Bug-Reference-ID: <556CE1CE-E1AC-11D8-A2D9-00039383EC60@apple.com>
-Bug-Reference-URL:
-
-Bug-Description:
-
-vi-mode filename completion/glob expansion should understand and perform
-tilde expansion.
-
-Patch:
-
-*** ../bash-3.0/bashline.c Mon Jul 5 23:22:12 2004
---- bashline.c Thu Sep 2 16:00:12 2004
+*** bash-3.0/bashline.c Mon Jul 5 23:22:12 2004
+--- bash/bashline.c Thu Sep 2 16:00:12 2004
***************
*** 2514,2518 ****
static int ind;
@@ -69,8 +52,8 @@ Patch:
matches = shell_glob_filename (globtext);
-*** ../bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
---- patchlevel.h Thu Sep 2 15:04:32 2004
+*** bash-3.0/patchlevel.h Wed Aug 22 08:05:39 2001
+--- bash/patchlevel.h Thu Sep 2 15:04:32 2004
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */