summaryrefslogtreecommitdiffstats
path: root/package/bash
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-01-11 14:38:24 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-17 21:06:38 +0100
commit0cce9228a1bcf1c228a75da366d110cf52c0d39d (patch)
tree357718a9748ba5c85881be0bc65e2a21608ff248 /package/bash
parent613ad08dd5f62a839bcb79501c94e36358fee71f (diff)
downloadbuildroot-novena-0cce9228a1bcf1c228a75da366d110cf52c0d39d.tar.gz
buildroot-novena-0cce9228a1bcf1c228a75da366d110cf52c0d39d.zip
bash: build after busybox
Make sure bash builds after busybox when it's enabled to override busybox's /bin/sh symlink with bash. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/bash/bash.mk b/package/bash/bash.mk
index d7bb699e1..2bcf0c43a 100644
--- a/package/bash/bash.mk
+++ b/package/bash/bash.mk
@@ -8,6 +8,11 @@ BASH_VERSION = 4.1
BASH_SITE = $(BR2_GNU_MIRROR)/bash
BASH_DEPENDENCIES = ncurses
+# Make sure we build after busybox so that /bin/sh links to bash
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+BASH_DEPENDENCIES += busybox
+endif
+
# Save the old sh file/link if there is one and symlink bash->sh
define BASH_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \