summaryrefslogtreecommitdiffstats
path: root/package/bash
diff options
context:
space:
mode:
authorNigel Kukard <nkukard@lbsd.net>2008-05-01 19:07:58 +0000
committerNigel Kukard <nkukard@lbsd.net>2008-05-01 19:07:58 +0000
commit02d713dcdd850456717eb6d6507dbf6ba44a58eb (patch)
tree0bf8910c80d66286cbe18de49e0f39d0f449d2f1 /package/bash
parent1aac1affcd17f99eaae553e799957f2ff4591cac (diff)
downloadbuildroot-novena-02d713dcdd850456717eb6d6507dbf6ba44a58eb.tar.gz
buildroot-novena-02d713dcdd850456717eb6d6507dbf6ba44a58eb.zip
* Fixed bash patches
Diffstat (limited to 'package/bash')
-rw-r--r--package/bash/bash32-0258
-rw-r--r--package/bash/bash32-02616
-rw-r--r--package/bash/bash32-0278
-rw-r--r--package/bash/bash32-0288
-rw-r--r--package/bash/bash32-0298
-rw-r--r--package/bash/bash32-0308
-rw-r--r--package/bash/bash32-0318
-rw-r--r--package/bash/bash32-0328
-rw-r--r--package/bash/bash32-03312
9 files changed, 42 insertions, 42 deletions
diff --git a/package/bash/bash32-025 b/package/bash/bash32-025
index 4d53d89d7..20f86074d 100644
--- a/package/bash/bash32-025
+++ b/package/bash/bash32-025
@@ -16,8 +16,8 @@ of data into a terminal window).
Patch:
-*** ../bash-3.2-patched/lib/readline/input.c Wed Aug 16 15:15:16 2006
---- lib/readline/input.c Tue Jul 17 09:24:21 2007
+*** bash-3.2-patched/lib/readline/input.c Wed Aug 16 15:15:16 2006
+--- bash-3.2/lib/readline/input.c Tue Jul 17 09:24:21 2007
***************
*** 134,139 ****
@@ -62,8 +62,8 @@ Patch:
+ #endif
push_index = 0;
-*** ../bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
---- patchlevel.h Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h Mon Oct 16 14:22:54 2006
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash32-026 b/package/bash/bash32-026
index ba7de50a8..8e7c2bdf1 100644
--- a/package/bash/bash32-026
+++ b/package/bash/bash32-026
@@ -22,8 +22,8 @@ bash.
Patch:
-*** ../bash-3.2-patched/configure.in 2007-03-06 11:07:38.000000000 -0500
---- configure.in 2007-11-23 15:37:41.000000000 -0500
+*** bash-3.2-patched/configure.in 2007-03-06 11:07:38.000000000 -0500
+--- bash-3.2/configure.in 2007-11-23 15:37:41.000000000 -0500
***************
*** 519,523 ****
# dynamic version
@@ -37,8 +37,8 @@ Patch:
! darwin[[89]]*) READLINE_LIB='${READLINE_LIBRARY}' ;;
*) READLINE_LIB=-lreadline ;;
esac
-*** ../bash-3.2-patched/configure 2007-03-24 14:51:22.000000000 -0400
---- configure 2007-11-23 15:46:15.000000000 -0500
+*** bash-3.2-patched/configure 2007-03-24 14:51:22.000000000 -0400
+--- bash-3.2/configure 2007-11-23 15:46:15.000000000 -0500
***************
*** 4872,4876 ****
# dynamic version
@@ -52,8 +52,8 @@ Patch:
! darwin[89]*) READLINE_LIB='${READLINE_LIBRARY}' ;;
*) READLINE_LIB=-lreadline ;;
esac
-*** ../bash-3.2-patched/version.c 2005-05-16 11:58:34.000000000 -0400
---- version.c 2007-11-23 16:03:40.000000000 -0500
+*** bash-3.2-patched/version.c 2005-05-16 11:58:34.000000000 -0400
+--- bash-3.2/version.c 2007-11-23 16:03:40.000000000 -0500
***************
*** 80,83 ****
printf ("GNU bash, version %s (%s)\n", shell_version_string (), MACHTYPE);
@@ -65,8 +65,8 @@ Patch:
if (extended)
! printf (_("Copyright (C) 2007 Free Software Foundation, Inc.\n"));
}
-*** ../bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
---- patchlevel.h Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h Mon Oct 16 14:22:54 2006
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash32-027 b/package/bash/bash32-027
index 5e110cb96..289914cfd 100644
--- a/package/bash/bash32-027
+++ b/package/bash/bash32-027
@@ -16,8 +16,8 @@ prompt contains invisible characters and a newline.
Patch:
-*** ../bash-3.2.25/lib/readline/display.c Mon Aug 6 14:26:29 2007
---- lib/readline/display.c Wed Oct 10 22:43:58 2007
+*** bash-3.2.25/lib/readline/display.c Mon Aug 6 14:26:29 2007
+--- bash-3.2/lib/readline/display.c Wed Oct 10 22:43:58 2007
***************
*** 1049,1053 ****
else
@@ -68,8 +68,8 @@ Patch:
! _rl_last_c_pos == prompt_physical_chars)
cpos_adjusted = 1;
#endif
-*** ../bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
---- patchlevel.h Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h Mon Oct 16 14:22:54 2006
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash32-028 b/package/bash/bash32-028
index e8182948d..661c53827 100644
--- a/package/bash/bash32-028
+++ b/package/bash/bash32-028
@@ -15,8 +15,8 @@ containing invisible characters after the final newline.
Patch:
-*** ../bash-3.2-patched/lib/readline/display.c 2007-08-25 13:47:08.000000000 -0400
---- lib/readline/display.c 2007-11-10 17:51:29.000000000 -0500
+*** bash-3.2-patched/lib/readline/display.c 2007-08-25 13:47:08.000000000 -0400
+--- bash-3.2/lib/readline/display.c 2007-11-10 17:51:29.000000000 -0500
***************
*** 392,396 ****
local_prompt = expand_prompt (p, &prompt_visible_length,
@@ -43,8 +43,8 @@ Patch:
! (int *)NULL,
(int *)NULL);
*t = c;
-*** ../bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
---- patchlevel.h Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h Mon Oct 16 14:22:54 2006
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash32-029 b/package/bash/bash32-029
index 9de208584..34c84f139 100644
--- a/package/bash/bash32-029
+++ b/package/bash/bash32-029
@@ -16,8 +16,8 @@ operator, and an error occurs, evaluation is not re-enabled.
Patch:
-*** ../bash-3.2-patched/expr.c 2007-08-25 13:47:05.000000000 -0400
---- expr.c 2007-10-18 08:08:44.000000000 -0400
+*** bash-3.2-patched/expr.c 2007-08-25 13:47:05.000000000 -0400
+--- bash-3.2/expr.c 2007-10-18 08:08:44.000000000 -0400
***************
*** 287,290 ****
--- 287,292 ----
@@ -35,8 +35,8 @@ Patch:
+ noeval = 0;
FASTCOPY (evalbuf, oevalbuf, sizeof (evalbuf));
-*** ../bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
---- patchlevel.h Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h Mon Oct 16 14:22:54 2006
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash32-030 b/package/bash/bash32-030
index 3f12c2833..dc7792155 100644
--- a/package/bash/bash32-030
+++ b/package/bash/bash32-030
@@ -16,8 +16,8 @@ first in a sequential list.
Patch:
-*** ../bash-3.2-patched/execute_cmd.c 2007-03-24 14:51:05.000000000 -0400
---- execute_cmd.c 2007-11-05 22:31:14.000000000 -0500
+*** bash-3.2-patched/execute_cmd.c 2007-03-24 14:51:05.000000000 -0400
+--- bash-3.2/execute_cmd.c 2007-11-05 22:31:14.000000000 -0500
***************
*** 615,619 ****
redirection_undo_list = (REDIRECT *)NULL;
@@ -31,8 +31,8 @@ Patch:
! return (last_command_exit_value = EXECUTION_FAILURE);
}
-*** ../bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
---- patchlevel.h Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h Mon Oct 16 14:22:54 2006
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash32-031 b/package/bash/bash32-031
index 6c96fb9d0..f025da381 100644
--- a/package/bash/bash32-031
+++ b/package/bash/bash32-031
@@ -17,8 +17,8 @@ text being drawn begins before the last invisible character in the line.
Patch:
-*** ../bash-3.2-patched/lib/readline/display.c 2007-08-25 13:47:08.000000000 -0400
---- lib/readline/display.c 2007-11-10 17:51:29.000000000 -0500
+*** bash-3.2-patched/lib/readline/display.c 2007-08-25 13:47:08.000000000 -0400
+--- bash-3.2/lib/readline/display.c 2007-11-10 17:51:29.000000000 -0500
***************
*** 1566,1574 ****
else
@@ -45,8 +45,8 @@ Patch:
+ }
return;
}
-*** ../bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
---- patchlevel.h Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h Mon Oct 16 14:22:54 2006
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash32-032 b/package/bash/bash32-032
index 5e53e2919..bce4c23e6 100644
--- a/package/bash/bash32-032
+++ b/package/bash/bash32-032
@@ -15,8 +15,8 @@ very quickly in succession, causing characters to be dropped.
Patch:
-*** ../bash-3.2-patched/lib/readline/input.c 2007-08-25 13:47:10.000000000 -0400
---- lib/readline/input.c 2007-10-12 22:55:25.000000000 -0400
+*** bash-3.2-patched/lib/readline/input.c 2007-08-25 13:47:10.000000000 -0400
+--- bash-3.2/lib/readline/input.c 2007-10-12 22:55:25.000000000 -0400
***************
*** 155,159 ****
pop_index--;
@@ -30,8 +30,8 @@ Patch:
! pop_index = ibuffer_len;
ibuffer[pop_index] = key;
return (1);
-*** ../bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
---- patchlevel.h Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h Mon Oct 16 14:22:54 2006
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */
diff --git a/package/bash/bash32-033 b/package/bash/bash32-033
index 0d698108b..89bc35d62 100644
--- a/package/bash/bash32-033
+++ b/package/bash/bash32-033
@@ -16,8 +16,8 @@ ASCII 127 characters in the expanded value.
Patch:
-*** ../bash-3.2-patched/arrayfunc.c 2007-08-25 13:47:05.000000000 -0400
---- arrayfunc.c 2007-05-31 11:55:46.000000000 -0400
+*** bash-3.2-patched/arrayfunc.c 2007-08-25 13:47:05.000000000 -0400
+--- bash-3.2/arrayfunc.c 2007-05-31 11:55:46.000000000 -0400
***************
*** 723,727 ****
{
@@ -31,8 +31,8 @@ Patch:
! *rtype = (t[0] == '*') ? 1 : 2;
if (allow_all == 0)
{
-*** ../bash-3.2-patched/subst.c 2007-08-25 13:47:08.000000000 -0400
---- subst.c 2007-11-14 15:43:00.000000000 -0500
+*** bash-3.2-patched/subst.c 2007-08-25 13:47:08.000000000 -0400
+--- bash-3.2/subst.c 2007-11-14 15:43:00.000000000 -0500
***************
*** 4908,4915 ****
intmax_t arg_index;
@@ -70,8 +70,8 @@ Patch:
+ ret->flags |= rflags;
}
return ret;
-*** ../bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
---- patchlevel.h Mon Oct 16 14:22:54 2006
+*** bash-3.2/patchlevel.h Thu Apr 13 08:31:04 2006
+--- bash-3.2/patchlevel.h Mon Oct 16 14:22:54 2006
***************
*** 26,30 ****
looks for to find the patch level (for the sccs version string). */