summaryrefslogtreecommitdiffstats
path: root/package/avahi
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-02-28 15:53:49 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-28 16:04:54 +0100
commitdfee7243c65fd11118573fe3128db34993df037a (patch)
tree9aa89858624493b700cd3d8c88acdb5c9f123c5c /package/avahi
parent816303a49dc249584b9f3f29a1c38642d6685997 (diff)
downloadbuildroot-novena-dfee7243c65fd11118573fe3128db34993df037a.tar.gz
buildroot-novena-dfee7243c65fd11118573fe3128db34993df037a.zip
avahi: fix avahi access through dbus
Ensure that the avahi dbus service gets installed if dbus support is enabled, otherwise avahi access through dbus fails (as clients try to start the daemon and dbus doesn't know how to do this). Fixed upstream in 0.6.28 (http://avahi.org/ticket/319) but this workaround is simpler/safer for now. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/avahi')
-rw-r--r--package/avahi/avahi.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 8c0d920e9..63215572c 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -160,8 +160,19 @@ define AVAHI_INSTALL_DAEMON_INITSCRIPT
$(INSTALL) -m 0755 package/avahi/S50avahi-daemon $(TARGET_DIR)/etc/init.d/
endef
+# avahi build sys erroneously only installs dbus service if systemd is enabled
+define AVAHI_INSTALL_DAEMON_DBUS_SERVICE
+ $(INSTALL) -m 0644 -D $(@D)/avahi-daemon/org.freedesktop.Avahi.service \
+ $(TARGET_DIR)/usr/share/dbus-1/system-services/org.freedesktop.Avahi.service
+endef
+
ifeq ($(BR2_PACKAGE_AVAHI_DAEMON),y)
AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_INSTALL_DAEMON_INITSCRIPT
+
+ifeq ($(BR2_PACKAGE_DBUS),y)
+AVAHI_POST_INSTALL_TARGET_HOOKS += AVAHI_INSTALL_DAEMON_DBUS_SERVICE
+endif
+
endif
$(eval $(call AUTOTARGETS,package,avahi))