summaryrefslogtreecommitdiffstats
path: root/package/avahi
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
committerEric Andersen <andersen@codepoet.org>2007-01-14 03:52:21 +0000
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/avahi
parent4ac03cc86a989c2f86b2cdb7041b854bf9609049 (diff)
downloadbuildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-novena-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/avahi')
-rw-r--r--package/avahi/avahi.mk18
1 files changed, 5 insertions, 13 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index c53f5f10c..f939e7b7e 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -34,7 +34,6 @@ $(AVAHI_DIR)/.configured: $(AVAHI_DIR)/.unpacked
CFLAGS="$(TARGET_CFLAGS)" \
LIBDAEMON_CFLAGS="-I$(STAGING_DIR)/include" \
LIBDAEMON_LIBS="-L$(STAGING_DIR)/lib -ldaemon" \
- PKG_CONFIG_PATH="$(LIBDAEMON_DIR)" \
ac_cv_func_strtod=yes \
ac_fsusage_space=yes \
fu_cv_sys_stat_statfs2_bsize=yes \
@@ -90,19 +89,20 @@ $(AVAHI_DIR)/.configured: $(AVAHI_DIR)/.unpacked
ac_use_included_regex=no \
./configure \
--target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
+ --host=$(REAL_GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
- --libexecdir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/usr/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
+ --includedir=/include \
--mandir=/usr/man \
--infodir=/usr/info \
- --includedir=$(STAGING_DIR)/include \
$(DISABLE_NLS) \
$(DISABLE_LARGEFILE) \
--disable-glib \
@@ -130,15 +130,7 @@ $(AVAHI_DIR)/.compiled: $(AVAHI_DIR)/.configured
touch $(AVAHI_DIR)/.compiled
$(STAGING_DIR)/sbin/avahi-autoipd: $(AVAHI_DIR)/.compiled
- $(MAKE) \
- -C $(AVAHI_DIR)/avahi-autoipd \
- prefix=$(STAGING_DIR) \
- exec_prefix=$(STAGING_DIR) \
- bindir=$(STAGING_DIR)/bin \
- datadir=$(STAGING_DIR)/share \
- sbindir=$(STAGING_DIR)/sbin \
- sysconfdir=$(STAGING_DIR)/etc \
- install
+ $(MAKE) DESTDIR=$(STAGING_DIR) -C $(AVAHI_DIR)/avahi-autoipd install
touch -c $(STAGING_DIR)/sbin/avahi-autoipd
$(TARGET_DIR)/usr/sbin/avahi-autoipd: $(STAGING_DIR)/sbin/avahi-autoipd