summaryrefslogtreecommitdiffstats
path: root/package/avahi
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-13 15:38:03 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-13 15:38:03 +0000
commit6c687a3fb3322c434f34535ed2c6234fbf230160 (patch)
treefb1259d428b77f38373a331af786958ea2f22033 /package/avahi
parent038f536294738a4ef58b0bce54b3c46cd151ec57 (diff)
downloadbuildroot-novena-6c687a3fb3322c434f34535ed2c6234fbf230160.tar.gz
buildroot-novena-6c687a3fb3322c434f34535ed2c6234fbf230160.zip
avahi: enable python support if python is enabled
Not particular useful until we add dbus-python (which depends on a fixed up dbus-glib, which in turn depends on us starting to compile glib/dbus/dbus-glib for the host as well) - But that's for another day.
Diffstat (limited to 'package/avahi')
-rw-r--r--package/avahi/avahi.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/avahi/avahi.mk b/package/avahi/avahi.mk
index 77f4f3601..032edfd6a 100644
--- a/package/avahi/avahi.mk
+++ b/package/avahi/avahi.mk
@@ -78,7 +78,6 @@ AVAHI_CONF_OPT = --localstatedir=/var \
--disable-qt4 \
--disable-gtk \
--disable-gdbm \
- --disable-python \
--disable-python-dbus \
--disable-pygtk \
--disable-mono \
@@ -113,6 +112,21 @@ else
AVAHI_CONF_OPT += --disable-dbus
endif
+ifeq ($(BR2_PACKAGE_PYTHON),y)
+AVAHI_CONF_ENV += am_cv_pathless_PYTHON=python \
+ am_cv_path_PYTHON=$(PYTHON_TARGET_BINARY) \
+ am_cv_python_version=$(PYTHON_VERSION) \
+ am_cv_python_platform=linux2 \
+ am_cv_python_pythondir=$(PYTHON_SITE_PACKAGE_DIR) \
+ am_cv_python_pyexecdir=$(PYTHON_SITE_PACKAGE_DIR) \
+ py_cv_mod_socket_=yes
+
+AVAHI_DEPENDENCIES += libpython
+AVAHI_CONF_OPT += --enable-python
+else
+AVAHI_CONF_OPT += --disable-python
+endif
+
ifeq ($(BR2_PACKAGE_LIBINTL),y)
AVAHI_DEPENDENCIES += libintl
AVAHI_MAKE_OPT = LIBS=-lintl