summaryrefslogtreecommitdiffstats
path: root/package/automake
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-03-29 19:10:26 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2009-03-29 19:10:26 +0000
commit6099e286e2b254517bb8ec63cad5131b1dc9539b (patch)
treedc928c090b28cfaac1c2dea3a37fbd047b837767 /package/automake
parentfb56c53e3938c6a2911b4bb22b82219aa5943dce (diff)
downloadbuildroot-novena-6099e286e2b254517bb8ec63cad5131b1dc9539b.tar.gz
buildroot-novena-6099e286e2b254517bb8ec63cad5131b1dc9539b.zip
package: proper aclocal fix
Revert r25827 and instead copy over the host aclocal files of the stuff needed for auto* (libtool + pkgconfig). These logically belong with the target stuff, as they are used for the target auto* toolchain. Long term we should probably consider using aclocal --acdir=$(STAGING_DIR)/usr/share/aclocal, so the host .m4 files cannot interfere with the target build.
Diffstat (limited to 'package/automake')
-rw-r--r--package/automake/automake.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/automake/automake.mk b/package/automake/automake.mk
index d65cd2338..6b87caa92 100644
--- a/package/automake/automake.mk
+++ b/package/automake/automake.mk
@@ -20,7 +20,7 @@ AUTOMAKE_HOST_DIR:=$(BUILD_DIR)/automake-$(AUTOMAKE_VERSION)-host
# variables used by other packages
AUTOMAKE:=$(HOST_DIR)/usr/bin/automake
-ACLOCAL_DIR = $(HOST_DIR)/usr/share/aclocal
+ACLOCAL_DIR = $(STAGING_DIR)/usr/share/aclocal
ACLOCAL = $(HOST_DIR)/usr/bin/aclocal -I $(ACLOCAL_DIR)
$(DL_DIR)/$(AUTOMAKE_SOURCE):
@@ -51,6 +51,7 @@ $(STAMP_DIR)/host_automake_compiled: $(STAMP_DIR)/host_automake_configured
$(STAMP_DIR)/host_automake_installed: $(STAMP_DIR)/host_automake_compiled
$(MAKE) -C $(AUTOMAKE_HOST_DIR) install
+ mkdir -p $(STAGING_DIR)/usr/share/aclocal
touch $@
host-automake: $(STAMP_DIR)/host_automake_installed