summaryrefslogtreecommitdiffstats
path: root/package/autoconf
diff options
context:
space:
mode:
authorLionel Landwerlin <llandwerlin@gmail.com>2010-12-26 17:16:35 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-28 20:33:20 +0100
commita68640c31dbf216eb5862d76daefce4b7e754795 (patch)
treee5710662cb4cc117b55a4d2be84ebf961349684a /package/autoconf
parent58ddf43464ab3892d2af0c3973e6d9ef31653fdf (diff)
downloadbuildroot-novena-a68640c31dbf216eb5862d76daefce4b7e754795.tar.gz
buildroot-novena-a68640c31dbf216eb5862d76daefce4b7e754795.zip
package: avoid copying .m4 files from host to staging
Since we are preparing a package generation mechanism, we would like to avoid packages that move/touch/modify files which are not part of their own package. That's why we try to not install host files into the staging directory (in this case .m4 files) and instead we include $(HOST_DIR)/usr/share/aclocal into autoreconf search directory. Signed-off-by: Lionel Landwerlin <llandwerlin@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/autoconf')
-rw-r--r--package/autoconf/autoconf.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/autoconf/autoconf.mk b/package/autoconf/autoconf.mk
index a21192f22..0ff0644f9 100644
--- a/package/autoconf/autoconf.mk
+++ b/package/autoconf/autoconf.mk
@@ -23,4 +23,4 @@ $(eval $(call AUTOTARGETS,package,autoconf,host))
# variables used by other packages
AUTOCONF:=$(HOST_DIR)/usr/bin/autoconf
AUTOHEADER:=$(HOST_DIR)/usr/bin/autoheader
-AUTORECONF=$(HOST_CONFIGURE_OPTS) ACLOCAL="$(ACLOCAL)" AUTOCONF="$(AUTOCONF)" AUTOHEADER="$(AUTOHEADER)" AUTOMAKE="$(AUTOMAKE)" $(HOST_DIR)/usr/bin/autoreconf -f -i -I "$(ACLOCAL_DIR)"
+AUTORECONF=$(HOST_CONFIGURE_OPTS) ACLOCAL="$(ACLOCAL)" AUTOCONF="$(AUTOCONF)" AUTOHEADER="$(AUTOHEADER)" AUTOMAKE="$(AUTOMAKE)" $(HOST_DIR)/usr/bin/autoreconf -f -i -I "$(ACLOCAL_DIR)" -I "$(ACLOCAL_HOST_DIR)"