summaryrefslogtreecommitdiffstats
path: root/package/autoconf
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-07-29 08:39:02 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-29 08:39:02 +0200
commit7ee8ebbd813ad0a6d2392ef628c1724104f0619b (patch)
tree953137f17ac6d83ad599833ffab71d991b757b91 /package/autoconf
parent6486661a6b41158535d785db9e1e403f7216b5d9 (diff)
downloadbuildroot-novena-7ee8ebbd813ad0a6d2392ef628c1724104f0619b.tar.gz
buildroot-novena-7ee8ebbd813ad0a6d2392ef628c1724104f0619b.zip
autoconf: use dummy autopoint
We currently don't build a host-gettext package, so when a package using gettext is autoreconf'ed, we end up using autopoint from the host. Autopoint unfortunately requires CVS, so if that isn't available autoreconf fails. From reading: http://www.gnu.org/software/gnulib/manual/html_node/gettextize-and-autopoint.html It seems that we don't really need to rerun autopoint, so fix it by passing autopoint=/bin/true instead. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/autoconf')
-rw-r--r--package/autoconf/autoconf.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/autoconf/autoconf.mk b/package/autoconf/autoconf.mk
index 0ff0644f9..45bb63530 100644
--- a/package/autoconf/autoconf.mk
+++ b/package/autoconf/autoconf.mk
@@ -23,4 +23,4 @@ $(eval $(call AUTOTARGETS,package,autoconf,host))
# variables used by other packages
AUTOCONF:=$(HOST_DIR)/usr/bin/autoconf
AUTOHEADER:=$(HOST_DIR)/usr/bin/autoheader
-AUTORECONF=$(HOST_CONFIGURE_OPTS) ACLOCAL="$(ACLOCAL)" AUTOCONF="$(AUTOCONF)" AUTOHEADER="$(AUTOHEADER)" AUTOMAKE="$(AUTOMAKE)" $(HOST_DIR)/usr/bin/autoreconf -f -i -I "$(ACLOCAL_DIR)" -I "$(ACLOCAL_HOST_DIR)"
+AUTORECONF=$(HOST_CONFIGURE_OPTS) ACLOCAL="$(ACLOCAL)" AUTOCONF="$(AUTOCONF)" AUTOHEADER="$(AUTOHEADER)" AUTOMAKE="$(AUTOMAKE)" AUTOPOINT=/bin/true $(HOST_DIR)/usr/bin/autoreconf -f -i -I "$(ACLOCAL_DIR)" -I "$(ACLOCAL_HOST_DIR)"