summaryrefslogtreecommitdiffstats
path: root/package/attr
diff options
context:
space:
mode:
authorYegor Yefremov <yegor_sub1@visionsystems.de>2011-07-13 11:12:29 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-13 15:02:38 +0200
commit691a5ead68deb5c77442f7a88ede479e57a9758c (patch)
tree6ba9417583a35b91c1c35f9ec22c5fb277536777 /package/attr
parentb28de60c24ad4bef4ff7a6ad51cbb6e79906c868 (diff)
downloadbuildroot-novena-691a5ead68deb5c77442f7a88ede479e57a9758c.tar.gz
buildroot-novena-691a5ead68deb5c77442f7a88ede479e57a9758c.zip
New package: attr
Commands for Manipulating Filesystem Extended Attributes. [Peter: needs largefile] Signed-off-by: Heiko Zuerker <smiley73@users.sourceforge.net> Signed-off-by: Daniel Mack <zonque@gmail.com> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/attr')
-rw-r--r--package/attr/Config.in11
-rw-r--r--package/attr/attr.mk27
2 files changed, 38 insertions, 0 deletions
diff --git a/package/attr/Config.in b/package/attr/Config.in
new file mode 100644
index 000000000..79f233680
--- /dev/null
+++ b/package/attr/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_ATTR
+ bool "attr"
+ depends on BR2_LARGEFILE
+ help
+ Commands for Manipulating Filesystem Extended Attributes.
+ This package also provides libattr.
+
+ http://savannah.nongnu.org/projects/attr
+
+comment "attr requires a toolchain with LARGEFILE support"
+ depends on !BR2_LARGEFILE
diff --git a/package/attr/attr.mk b/package/attr/attr.mk
new file mode 100644
index 000000000..b744ef6d1
--- /dev/null
+++ b/package/attr/attr.mk
@@ -0,0 +1,27 @@
+#############################################################
+#
+# attr
+#
+#############################################################
+
+ATTR_VERSION = 2.4.46
+ATTR_SOURCE = attr-$(ATTR_VERSION).src.tar.gz
+ATTR_SITE = http://download.savannah.gnu.org/releases/attr
+ATTR_INSTALL_STAGING = YES
+ATTR_CONF_OPT = --enable-gettext=no
+
+# While the configuration system uses autoconf, the Makefiles are
+# hand-written and do not use automake. Therefore, we have to hack
+# around their deficiencies by passing installation paths.
+ATTR_INSTALL_STAGING_OPT = \
+ prefix=$(STAGING_DIR)/usr \
+ exec_prefix=$(STAGING_DIR)/usr \
+ PKG_DEVLIB_DIR=$(STAGING_DIR)/usr/lib \
+ install-dev install-lib
+
+ATTR_INSTALL_TARGET_OPT = \
+ prefix=$(TARGET_DIR)/usr \
+ exec_prefix=$(TARGET_DIR)/usr \
+ install install-lib
+
+$(eval $(call AUTOTARGETS,package,attr))