summaryrefslogtreecommitdiffstats
path: root/package/atk
diff options
context:
space:
mode:
authorThiago A. CorrĂȘa <thiago.correa@gmail.com>2008-07-04 02:23:19 +0000
committerThiago A. CorrĂȘa <thiago.correa@gmail.com>2008-07-04 02:23:19 +0000
commit34112e2256a5078a99cd63b8779e8f87e95b573f (patch)
tree5342b64bdddb8d2ae08502a3d8d902db83126517 /package/atk
parentc1529a17566651af57296e34c08dd4d5253745aa (diff)
downloadbuildroot-novena-34112e2256a5078a99cd63b8779e8f87e95b573f.tar.gz
buildroot-novena-34112e2256a5078a99cd63b8779e8f87e95b573f.zip
Fix bug #3594: ATK does not always require X support to be compiled
Diffstat (limited to 'package/atk')
-rw-r--r--package/atk/atk.mk12
1 files changed, 9 insertions, 3 deletions
diff --git a/package/atk/atk.mk b/package/atk/atk.mk
index a069832a2..84b137388 100644
--- a/package/atk/atk.mk
+++ b/package/atk/atk.mk
@@ -42,6 +42,14 @@ ATK_CONF_ENV = ac_cv_func_posix_getpwuid_r=yes \
gl_cv_c_restrict=no ac_cv_path_GLIB_GENMARSHAL=/usr/bin/glib-genmarshal \
ac_cv_prog_F77=no ac_cv_prog_CXX=no
+ifneq ($(BR2_PACKAGE_XSERVER_none),y)
+ATK_CONF_OPT_X = --with-x \
+ --x-includes=$(STAGING_DIR)/usr/include/X11 \
+ --x-libraries=$(STAGING_DIR)/usr/lib
+else
+ATK_CONF_OPT_X = --without-x
+endif
+
ATK_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(REAL_GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) --prefix=/usr \
--exec-prefix=/usr --bindir=/usr/bin \
@@ -50,9 +58,7 @@ ATK_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(REAL_GNU_TARGET_NAME) \
--datadir=/usr/share --localstatedir=/var \
--includedir=/usr/include --mandir=/usr/man \
--infodir=/usr/info --enable-shared \
- --enable-static --with-x \
- --x-includes=$(STAGING_DIR)/usr/include/X11 \
- --x-libraries=$(STAGING_DIR)/usr/lib \
+ --enable-static $(ATK_CONF_OPT_X) \
--disable-glibtest --enable-explicit-deps=no \
--disable-debug