summaryrefslogtreecommitdiffstats
path: root/package/at/at-3.1.12-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-01-28 16:03:06 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-01-28 16:05:40 +0100
commit97ab9b4c4150bbf5fb973664cbc1f5fad28da41a (patch)
tree5299b4d20380220a2485f426afa99ec2fa52501b /package/at/at-3.1.12-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch
parent819e7f5b788f63bb316afea53325b045337f208a (diff)
downloadbuildroot-novena-97ab9b4c4150bbf5fb973664cbc1f5fad28da41a.tar.gz
buildroot-novena-97ab9b4c4150bbf5fb973664cbc1f5fad28da41a.zip
at: bump version, fix make install, convert to Makefile.autotools.in format
Make install would fail if target != host, as it tried to use host strip for install -s. Patch 1-5 from ptxdist. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/at/at-3.1.12-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch')
-rw-r--r--package/at/at-3.1.12-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/package/at/at-3.1.12-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch b/package/at/at-3.1.12-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch
new file mode 100644
index 000000000..e1ab3d376
--- /dev/null
+++ b/package/at/at-3.1.12-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch
@@ -0,0 +1,38 @@
+From 8720a71757f3626bf3bbc3a7aa2185e6387e5689 Mon Sep 17 00:00:00 2001
+From: Marc Kleine-Budde <mkl@pengutronix.de>
+Date: Tue, 1 Dec 2009 20:37:31 +0100
+Subject: [PATCH 3/5] Makefile.in: add LDFLAGS to linking stage
+
+The linking stage ignores the LDFLAGS, this breaks if the flex library
+lives in a non standard location.
+
+This patch add LDFLAGS to both "at" and "atd" linking stage.
+
+Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
+---
+ Makefile.in | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index dae6b7d..b766bbb 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -65,13 +65,13 @@ LIST = Filelist Filelist.asc
+ all: at atd atrun
+
+ at: $(ATOBJECTS)
+- $(CC) $(CFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB)
+ rm -f $(CLONES)
+ $(LN_S) -f at atq
+ $(LN_S) -f at atrm
+
+ atd: $(RUNOBJECTS)
+- $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB)
+
+ y.tab.c y.tab.h: parsetime.y
+ $(YACC) -d parsetime.y
+--
+1.6.5.3
+