summaryrefslogtreecommitdiffstats
path: root/package/at/at-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch
diff options
context:
space:
mode:
authorJerzy Grzegorek <jerzy.grzegorek@trzebnica.net>2013-04-13 06:52:41 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-28 20:33:15 +0200
commit41de02bd0277f5df5ce575f08f06958237fb2de7 (patch)
treea9603d5c62c48d7bd06de827df89a5a902b90209 /package/at/at-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch
parentb1c79ec15e724939d7ef2b2357d1f25de3a940f0 (diff)
downloadbuildroot-novena-41de02bd0277f5df5ce575f08f06958237fb2de7.tar.gz
buildroot-novena-41de02bd0277f5df5ce575f08f06958237fb2de7.zip
at: bump to version 3.1.13
Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/at/at-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch')
-rw-r--r--package/at/at-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/package/at/at-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch b/package/at/at-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch
new file mode 100644
index 000000000..e1ab3d376
--- /dev/null
+++ b/package/at/at-0003-Makefile.in-add-LDFLAGS-to-linking-stage.patch
@@ -0,0 +1,38 @@
+From 8720a71757f3626bf3bbc3a7aa2185e6387e5689 Mon Sep 17 00:00:00 2001
+From: Marc Kleine-Budde <mkl@pengutronix.de>
+Date: Tue, 1 Dec 2009 20:37:31 +0100
+Subject: [PATCH 3/5] Makefile.in: add LDFLAGS to linking stage
+
+The linking stage ignores the LDFLAGS, this breaks if the flex library
+lives in a non standard location.
+
+This patch add LDFLAGS to both "at" and "atd" linking stage.
+
+Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
+---
+ Makefile.in | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index dae6b7d..b766bbb 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -65,13 +65,13 @@ LIST = Filelist Filelist.asc
+ all: at atd atrun
+
+ at: $(ATOBJECTS)
+- $(CC) $(CFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o at $(ATOBJECTS) $(LIBS) $(LEXLIB)
+ rm -f $(CLONES)
+ $(LN_S) -f at atq
+ $(LN_S) -f at atrm
+
+ atd: $(RUNOBJECTS)
+- $(CC) $(CFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o atd $(RUNOBJECTS) $(LIBS) $(PAMLIB)
+
+ y.tab.c y.tab.h: parsetime.y
+ $(YACC) -d parsetime.y
+--
+1.6.5.3
+