summaryrefslogtreecommitdiffstats
path: root/package/arptables
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-10-30 02:29:53 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-03 19:14:18 +0100
commitefc10eb6b87884f1f7917462d78af6953fcd99e3 (patch)
treea528e6c865f8b2b6cfe061408ec37a32d15da12d /package/arptables
parentb3770a8dc2c93c0a97786846e4c60037e52e7579 (diff)
downloadbuildroot-novena-efc10eb6b87884f1f7917462d78af6953fcd99e3.tar.gz
buildroot-novena-efc10eb6b87884f1f7917462d78af6953fcd99e3.zip
arptables: add new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/arptables')
-rw-r--r--package/arptables/Config.in6
-rw-r--r--package/arptables/arptables.mk21
2 files changed, 27 insertions, 0 deletions
diff --git a/package/arptables/Config.in b/package/arptables/Config.in
new file mode 100644
index 000000000..510eedf3b
--- /dev/null
+++ b/package/arptables/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_ARPTABLES
+ bool "arptables"
+ help
+ Tool to set up, maintain, and inspect the tables of ARP rules.
+
+ http://ebtables.sourceforge.net
diff --git a/package/arptables/arptables.mk b/package/arptables/arptables.mk
new file mode 100644
index 000000000..dac5ca470
--- /dev/null
+++ b/package/arptables/arptables.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# arptables
+#
+#############################################################
+
+ARPTABLES_VERSION = 0.0.3
+ARPTABLES_VERSION_MINOR = 4
+ARPTABLES_SOURCE = arptables-v$(ARPTABLES_VERSION)-$(ARPTABLES_VERSION_MINOR).tar.gz
+ARPTABLES_SITE = http://downloads.sourceforge.net/project/ebtables/arptables/arptables-v$(ARPTABLES_VERSION)
+
+define ARPTABLES_BUILD_CMDS
+ $(MAKE) -C $(@D) \
+ CC="$(TARGET_CC)" COPT_FLAGS="$(TARGET_CFLAGS)"
+endef
+
+define ARPTABLES_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 755 -D $(@D)/arptables $(TARGET_DIR)/usr/sbin/arptables
+endef
+
+$(eval $(generic-package))