summaryrefslogtreecommitdiffstats
path: root/package/am33x-cm3/am33x-cm3.mk
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2013-05-14 10:09:51 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-14 22:49:11 +0200
commit97fbd80efe6dd29b5d8d5393ea0a4cbc314dcfc6 (patch)
tree0dcc7d067fce746c650a54b8ce8cdb01305a6950 /package/am33x-cm3/am33x-cm3.mk
parent0012b7dcdb7f5cb5e6f22f08fcc6124979c1c9ea (diff)
downloadbuildroot-novena-97fbd80efe6dd29b5d8d5393ea0a4cbc314dcfc6.tar.gz
buildroot-novena-97fbd80efe6dd29b5d8d5393ea0a4cbc314dcfc6.zip
am33x-cm3: add FW for suspend/resume
Without this firmware, the beaglebone won't be able to suspend/resume correctly. [Peter: tweak Config.in, rename init script, wrap long lines] Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/am33x-cm3/am33x-cm3.mk')
-rw-r--r--package/am33x-cm3/am33x-cm3.mk30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/am33x-cm3/am33x-cm3.mk b/package/am33x-cm3/am33x-cm3.mk
new file mode 100644
index 000000000..3805c8022
--- /dev/null
+++ b/package/am33x-cm3/am33x-cm3.mk
@@ -0,0 +1,30 @@
+#############################################################
+#
+# am33x-cm3
+#
+#############################################################
+
+AM33X_CM3_VERSION = AM335xPSP_04.06.00.10-rc1
+AM33X_CM3_SITE = http://arago-project.org/git/projects/am33x-cm3.git
+AM33X_CM3_SITE_METHOD = git
+AM33X_CM3_LICENSE = TI Publicly Available Software License
+AM33X_CM3_LICENSE_FILES = License.txt
+
+# The build command below will use the standard cross-compiler (normally
+# build for Cortex-A8, to build the FW for the Cortex-M3.
+define AM33X_CM3_BUILD_CMDS
+ $(MAKE) CC="$(TARGET_CC)" CROSS_COMPILE="$(TARGET_CROSS)" -C $(@D) all
+endef
+
+# Not all of the firmware files are used
+define AM33X_CM3_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0644 -D $(@D)/bin/am335x-pm-firmware.bin \
+ $(TARGET_DIR)/lib/firmware/am335x-pm-firmware.bin
+endef
+
+define AM33X_CM3_INSTALL_INIT_SYSV
+ $(INSTALL) -m 0755 -D package/am33x-cm3/S93-am335x-pm-firmware-load \
+ $(TARGET_DIR)/etc/init.d/S93-am335x-pm-firmware-load
+endef
+
+$(eval $(generic-package))