summaryrefslogtreecommitdiffstats
path: root/package/acl/acl.mk
diff options
context:
space:
mode:
authorYegor Yefremov <yegor_sub1@visionsystems.de>2011-07-13 11:13:59 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-13 15:02:54 +0200
commit41d2a1477233231ae0445d5ac07320290b686b4e (patch)
treee82f33c3bc6bd603bcede9cc922e767b8add23b3 /package/acl/acl.mk
parent691a5ead68deb5c77442f7a88ede479e57a9758c (diff)
downloadbuildroot-novena-41d2a1477233231ae0445d5ac07320290b686b4e.tar.gz
buildroot-novena-41d2a1477233231ae0445d5ac07320290b686b4e.zip
New package: acl
POSIX Access Control Lists, which are used to define more fine-grained discretionary access rights for files and directories. [Peter: needs largefile] Signed-off-by: Heiko Zuerker <smiley73@users.sourceforge.net> Signed-off-by: Daniel Mack <zonque@gmail.com> Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/acl/acl.mk')
-rw-r--r--package/acl/acl.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/acl/acl.mk b/package/acl/acl.mk
new file mode 100644
index 000000000..11768f617
--- /dev/null
+++ b/package/acl/acl.mk
@@ -0,0 +1,28 @@
+#############################################################
+#
+# acl
+#
+#############################################################
+
+ACL_VERSION = 2.2.51
+ACL_SOURCE = acl-$(ACL_VERSION).src.tar.gz
+ACL_SITE = http://download.savannah.gnu.org/releases/acl
+ACL_INSTALL_STAGING = YES
+ACL_DEPENDENCIES = attr
+ACL_CONF_OPT = --enable-gettext=no
+
+# While the configuration system uses autoconf, the Makefiles are
+# hand-written and do not use automake. Therefore, we have to hack
+# around their deficiencies by passing installation paths.
+ACL_INSTALL_STAGING_OPT = \
+ prefix=$(STAGING_DIR)/usr \
+ exec_prefix=$(STAGING_DIR)/usr \
+ PKG_DEVLIB_DIR=$(STAGING_DIR)/usr/lib \
+ install-dev install-lib
+
+ACL_INSTALL_TARGET_OPT = \
+ prefix=$(TARGET_DIR)/usr \
+ exec_prefix=$(TARGET_DIR)/usr \
+ install install-lib
+
+$(eval $(call AUTOTARGETS,package,acl))