summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorBaruch Siach <baruch@tkos.co.il>2011-06-23 12:21:21 +0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-25 08:31:15 +0200
commitec8eda419a54674a0d326ea25bd9c440cd059065 (patch)
tree3853d482c68d3563daf0d1209d4b9dfa59a05cdf /package/Makefile.in
parent0af4136c544aecf7950a76996fd76cc8c208d604 (diff)
downloadbuildroot-novena-ec8eda419a54674a0d326ea25bd9c440cd059065.tar.gz
buildroot-novena-ec8eda419a54674a0d326ea25bd9c440cd059065.zip
toolchain: add user defined target LDFLAGS options
Allow the user to specify additional options for the target LDFLAGS. I use this to pass the -te500v2 option to the linker, when using the CodeSourcery toolchain for PowerPC. This chooses the correct CRT for e500 hard float. Otherwise I get errors like undefined reference to `_save32gpr_31' undefined reference to `_rest32gpr_31_x' at final link time. [Peter: fixup, use qstrip] Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 8e9637ce8..c3af5d3ea 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -77,6 +77,7 @@ TARGET_CFLAGS+=-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
endif
TARGET_CXXFLAGS=$(TARGET_CFLAGS)
+TARGET_LDFLAGS=$(call qstrip,$(BR2_TARGET_LDFLAGS))
ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_CTNG),y)
TARGET_CROSS=$(HOST_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-