summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-04-17 04:45:31 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-04-25 09:00:51 +0200
commitce1acfb5eae64e8042016ec36cf4973fbec707ca (patch)
tree1cf0eb0ad8d7d8972c4590614e3a7f0d330df921 /package/Makefile.in
parent2b563d481fbeeabc1c904e2398ec99a453faf6f2 (diff)
downloadbuildroot-novena-ce1acfb5eae64e8042016ec36cf4973fbec707ca.tar.gz
buildroot-novena-ce1acfb5eae64e8042016ec36cf4973fbec707ca.zip
toolchain: remove toolchain/Makefile.in and toolchain/gcc/Makefile.in
Re-integrate in gcc-uclibc-4.x.mk things from toolchain/gcc/Makefile.in that were completely gcc-specific. There was no reason to pull that when building with other backends than the internal one. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 14a554a3b..df7042c6a 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -50,6 +50,8 @@ REAL_GNU_TARGET_NAME=$(ARCH)-unknown-linux-$(LIBC)$(ABI)
STAGING_DIR=$(HOST_DIR)/usr/$(REAL_GNU_TARGET_NAME)/sysroot
+TARGET_OPTIMIZATION:=$(call qstrip,$(BR2_TARGET_OPTIMIZATION))
+
ifeq ($(BR2_OPTIMIZE_0),y)
TARGET_OPTIMIZATION+=-O0
endif