summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-07-15 01:12:05 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-02-05 15:06:31 +0100
commitbefb9a3ee0c5994162f527d8ef763d57d68ec48e (patch)
tree44a033a7d2a4582a4eb598fb1c443792e58d48e4 /package/Makefile.in
parent1b2ab4a43c2090f6d2b9c6b96db5c9284783d329 (diff)
downloadbuildroot-novena-befb9a3ee0c5994162f527d8ef763d57d68ec48e.tar.gz
buildroot-novena-befb9a3ee0c5994162f527d8ef763d57d68ec48e.zip
Make external toolchain relocatable
The external toolchain wrapper sets sysroot etc. to an absolute path. By changing this to a relative path, it is possible to move the host directory to a different location and still have a working build system. This only works for a downloaded external toolchain. For a pre-installed external toolchain, it is possible to move the host directory to a different location, but not the external toolchain directory (it does work if the external toolchain directory lies within the host directory). For an internal or crosstool-ng toolchain, there is no wrapper so updating the sysroot path should be done in a different way. See http://lists.busybox.net/pipermail/buildroot/2012-February/050371.html for information about others things to do to make the host directory relocatable. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 038bd9c9c..a8bf36b18 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -65,7 +65,8 @@ ifeq ($(BR2_xtensa),y)
TARGET_ABI += -mlongcalls
endif
-STAGING_DIR=$(HOST_DIR)/usr/$(GNU_TARGET_NAME)/sysroot
+STAGING_SUBDIR = usr/$(GNU_TARGET_NAME)/sysroot
+STAGING_DIR = $(HOST_DIR)/$(STAGING_SUBDIR)
TARGET_OPTIMIZATION:=$(call qstrip,$(BR2_TARGET_OPTIMIZATION))