summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorNathan Lynch <ntl@pobox.com>2012-06-11 16:09:37 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-06-24 11:09:21 +0200
commita72aed3a7434ed35599674a8405b1baee0f3df75 (patch)
tree5761114ae42e0b7f5840f907910787204f08d731 /package/Makefile.in
parent3cd8183f875a56ccffd0adf951ae6caed4b8b0a5 (diff)
downloadbuildroot-novena-a72aed3a7434ed35599674a8405b1baee0f3df75.tar.gz
buildroot-novena-a72aed3a7434ed35599674a8405b1baee0f3df75.zip
introduce PARALLEL_JOBS build system variable
BR2_JLEVEL currently is expanded directly in $(MAKE), and used in invocations of other build software (e.g. ct-ng). However, we are going to allow "0" to be a meaningful value for BR2_JLEVEL, which won't work for these uses. Given that it is not permissible to modify BR2_-prefixed variables in Makefiles, we need an intermediate variable. Define PARALLEL_JOBS to $(BR2_JLEVEL), and use the former in MAKE's definition. Uses of BR2_JLEVEL throughout the rest of the tree to be adjusted similarly in follow-up patches. Signed-off-by: Nathan Lynch <ntl@pobox.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 57599c5d4..be83ada1c 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -6,8 +6,10 @@ HOSTMAKE=$(MAKE)
endif
HOSTMAKE :=$(shell which $(HOSTMAKE) || type -p $(HOSTMAKE) || echo make)
+PARALLEL_JOBS:=$(BR2_JLEVEL)
+
MAKE1:=$(HOSTMAKE) -j1
-MAKE:=$(HOSTMAKE) -j$(BR2_JLEVEL)
+MAKE:=$(HOSTMAKE) -j$(PARALLEL_JOBS)
# Compute GNU_TARGET_NAME
GNU_TARGET_NAME=$(ARCH)-unknown-linux-$(LIBC)$(ABI)