summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-07-11 14:57:18 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-13 21:51:55 +0200
commit7ea1e92bdd9acf6cd5b021e61a18703e27885426 (patch)
treec43f51df11cc5c36bb1b62100ec31863a5a6a5f4 /package/Makefile.in
parentb8b57bb683283e68436de16cd1cc590b34d2d666 (diff)
downloadbuildroot-novena-7ea1e92bdd9acf6cd5b021e61a18703e27885426.tar.gz
buildroot-novena-7ea1e92bdd9acf6cd5b021e61a18703e27885426.zip
Remove -fPIC on x86_64
The -fPIC breaks the purgatory of kexec (= the code that passes command-line arguments to the kernel): kexec doesn't know how to handle the GOT and PLT relocation entries. There is also no reason at all to pass -fPIC. Shared libraries that require it will add it to their local Makefiles, and normal executables have no business with -fPIC (plus it adds overhead...). The -fPIC was added by Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> in commit 8027784c. That commit adds sysroot parameters to CFLAGS. There is no explanation why -fPIC is also added for x86_64. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in6
1 files changed, 0 insertions, 6 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index c5ad00aee..1c3ce482b 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -87,12 +87,6 @@ endif
TARGET_CFLAGS=$(TARGET_ABI) $(TARGET_OPTIMIZATION) $(TARGET_DEBUGGING)
-ifneq ($(BR2_PREFER_STATIC_LIB),y)
-ifeq ($(BR2_x86_64),y)
-TARGET_CFLAGS+=-fPIC -DPIC
-endif # PIC for dynamic objects on x86_64
-endif
-
ifeq ($(findstring yy,$(BR2_mips)$(BR2_MIPS_ABI64)),yy)
TARGET_CFLAGS+=-fno-pic -mno-abicalls
endif