summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorRichard Braun <rbraun@sceen.net>2012-11-20 07:18:11 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-30 13:59:40 -0800
commit6ae7886f84e8ca856854fa9ee1a15547f171e8c6 (patch)
treeef77a646dce4f71c3faa1bfc8309be1462bec253 /package/Makefile.in
parent696365f69bdf6261e8b312f98bdc177754bd5517 (diff)
downloadbuildroot-novena-6ae7886f84e8ca856854fa9ee1a15547f171e8c6.tar.gz
buildroot-novena-6ae7886f84e8ca856854fa9ee1a15547f171e8c6.zip
Makefile: fix thread libraries stripping
Strip libthread_db the same as any other library, but strip libpthread with --strip-debug. See the relevant mailing list discussion [1] for additional details. [1] http://lists.busybox.net/pipermail/buildroot/2012-October/060126.html Signed-off-by: Richard Braun <rbraun@sceen.net> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 2dd81c72c..8dea51eff 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -126,6 +126,7 @@ TARGET_CXX := $(CCACHE) $(TARGET_CXX)
endif
ifeq ($(BR2_STRIP_strip),y)
+STRIP_STRIP_DEBUG:=--strip-debug
STRIP_STRIP_UNNEEDED:=--strip-unneeded
STRIP_STRIP_ALL:=--strip-all
TARGET_STRIP=$(TARGET_CROSS)strip
@@ -133,6 +134,7 @@ STRIPCMD=$(TARGET_CROSS)strip --remove-section=.comment --remove-section=.note
KSTRIPCMD=$(STRIPCMD) $(STRIP_STRIP_UNNEEDED)
endif
ifeq ($(BR2_STRIP_sstrip),y)
+STRIP_STRIP_DEBUG:=
STRIP_STRIP_UNNEEDED:=
STRIP_STRIP_ALL:=
TARGET_STRIP=$(HOST_DIR)/usr/bin/$(GNU_TARGET_NAME)-sstrip