summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorSonic Zhang <sonic.zhang@analog.com>2011-03-10 19:12:41 +0800
committerPeter Korsgaard <jacmet@sunsite.dk>2011-03-28 10:00:37 +0200
commit5d6ff452add2d4e902409ed35accfa59adba37f2 (patch)
tree6abbad67253bca8abf019d6e8c621c8a4cb6f873 /package/Makefile.in
parent9b87631e34a7e430799d16506c6aa4f981253f36 (diff)
downloadbuildroot-novena-5d6ff452add2d4e902409ed35accfa59adba37f2.tar.gz
buildroot-novena-5d6ff452add2d4e902409ed35accfa59adba37f2.zip
external toolchain: Only prefix path if specified
Only prefix the external toolchain calls with its absolute path if BR2_TOOLCHAIN_EXTERNAL_PATH is set, otherwise just assume it will be available in the path. Signed-off-by: Sonic Zhang <sonic.zhang@analog.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index e1ffe158b..f98b3e792 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -115,7 +115,11 @@ TOOLCHAIN_EXTERNAL_LOCATION=$(TOOLCHAIN_EXTERNAL_DIR)
else
TOOLCHAIN_EXTERNAL_LOCATION=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PATH))
endif
+ifneq ($(TOOLCHAIN_EXTERNAL_LOCATION),)
TARGET_CROSS=$(TOOLCHAIN_EXTERNAL_LOCATION)/bin/$(TOOLCHAIN_EXTERNAL_PREFIX)-
+else
+TARGET_CROSS=$(TOOLCHAIN_EXTERNAL_PREFIX)-
+endif
endif
# Quotes are needed for spaces et al in path components.