summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:06:43 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-01-25 16:08:50 +0100
commit58d107ec3fb77b05bc16911a04ca7d42c46eb4d5 (patch)
treef12d510088d9ce4f2f1c827c5d542092846629e7 /package/Makefile.in
parent8442ae7946a8b09fb42d30537c79ddef14121d69 (diff)
downloadbuildroot-novena-58d107ec3fb77b05bc16911a04ca7d42c46eb4d5.tar.gz
buildroot-novena-58d107ec3fb77b05bc16911a04ca7d42c46eb4d5.zip
crosstool-ng: install toolchain into HOST_DIR like the internal toolchain
Simplifies code and helps us when we add SDK support in the future. With this we no longer need to copy headers/libraries to STAGING_DIR either. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in4
1 files changed, 1 insertions, 3 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 468d30c79..d3f51ad5f 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -106,7 +106,7 @@ TARGET_LDFLAGS+=-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib
TARGET_CXXFLAGS=$(TARGET_CFLAGS)
TARGET_SYSROOT_OPT=--sysroot=$(STAGING_DIR)
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_CTNG),y)
TARGET_CROSS=$(HOST_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL),y)
TOOLCHAIN_EXTERNAL_PREFIX=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PREFIX))
@@ -116,8 +116,6 @@ else
TOOLCHAIN_EXTERNAL_LOCATION=$(call qstrip,$(BR2_TOOLCHAIN_EXTERNAL_PATH))
endif
TARGET_CROSS=$(TOOLCHAIN_EXTERNAL_LOCATION)/bin/$(TOOLCHAIN_EXTERNAL_PREFIX)-
-else ifeq ($(BR2_TOOLCHAIN_CTNG),y)
-TARGET_CROSS=$(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-
endif
# Quotes are needed for spaces et al in path components.