summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-12-12 04:07:22 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-12 17:11:15 +0100
commit489970e047a78f7806747b99a7e1bd170fc5c75b (patch)
tree786cafc34b2e09afd8ade961e3204ac7820f4176 /package/Makefile.in
parent64c3ce4d886bea18f24231d09914c3be2ede144d (diff)
downloadbuildroot-novena-489970e047a78f7806747b99a7e1bd170fc5c75b.tar.gz
buildroot-novena-489970e047a78f7806747b99a7e1bd170fc5c75b.zip
pkg-infra: pass --disable-doc if documentation is not enabled
Many configure scripts support an option like --disable-doc, --disable-docs or --disable-documentation. Pass all of these to configure. In addition, not all Xorg packages accept the --disable-xxx. Instead they look for xmlto and/or fop and build documentation if they exist. For host packages, this may lead to build errors because /usr/bin/xmlto uses libxml2 and we set LD_LIBRARY_PATH to point to $(HOST_DIR)/lib, which may contain a libxml2 as well. So it's essential to disable xmlto for host packages. Also some whitespace cleanup. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 4281773a3..cc8f3202c 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -290,7 +290,15 @@ DISABLE_LARGEFILE= --disable-largefile
endif
ifneq ($(BR2_HAVE_DOCUMENTATION),y)
-DISABLE_DOCUMENTATION=--disable-gtk-doc
+# The configure option varies, but since unknown options are ignored
+# we can pass all of them.
+DISABLE_DOCUMENTATION = \
+ --disable-gtk-doc \
+ --disable-doc \
+ --disable-docs \
+ --disable-documentation \
+ --with-xmlto=no \
+ --with-fop=no
endif
ifeq ($(BR2_INET_IPV6),y)