summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-10-01 16:15:31 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-10-01 16:15:31 +0000
commit14a71561a388196edbcddfa72d281e911c06266f (patch)
treef9d8c334412e82c05aad398daefdee7d6bfea5e0 /package/Makefile.in
parent4ad141c338ef1f720d69b8d56a2be336128403e8 (diff)
downloadbuildroot-novena-14a71561a388196edbcddfa72d281e911c06266f.tar.gz
buildroot-novena-14a71561a388196edbcddfa72d281e911c06266f.zip
- just use the strip binary to avoid confusing libtool (quotes)
- use $(STRIPCMD) in packages to avoid clashes with $(STRIP)
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 3763cfcaf..0c2abcb1d 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -109,8 +109,8 @@ STRIP_STRIP_UNNEEDED:=--strip-unneeded
STRIP_STRIP_ALL:=--strip-all
REMOVE_SECTION_COMMENT:=--remove-section=.comment
REMOVE_SECTION_NOTE:=--remove-section=.note
-TARGET_STRIP=$(TARGET_CROSS)strip $(REMOVE_SECTION_COMMENT) $(REMOVE_SECTION_NOTE)
-STRIP=$(TARGET_STRIP)
+TARGET_STRIP=$(TARGET_CROSS)strip
+STRIPCMD=$(TARGET_CROSS)strip $(REMOVE_SECTION_COMMENT) $(REMOVE_SECTION_NOTE)
endif
ifeq ($(BR2_STRIP_sstrip),y)
STRIP_DISCARD_ALL:=
@@ -119,11 +119,11 @@ STRIP_STRIP_ALL:=
REMOVE_SECTION_COMMENT:=
REMOVE_SECTION_NOTE:=
TARGET_STRIP=$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-sstrip
-STRIP=$(TARGET_STRIP)
+STRIPCMD=$(TARGET_STRIP)
endif
ifeq ($(BR2_STRIP_none),y)
TARGET_STRIP=true -Not_stripping
-STRIP=$(TARGET_STRIP)
+STRIPCMD=$(TARGET_STRIP)
endif
INSTALL=/usr/bin/install