summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2012-10-02 23:26:30 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-04 22:49:58 +0200
commit11017f081fc5b034e680d89eaea729c19f450e01 (patch)
treef611b9d6d50791433189a40215b57b8d655246d9 /package/Makefile.in
parent3732b05b1dcdf79392b86ba1922b0d0f2ee8cced (diff)
downloadbuildroot-novena-11017f081fc5b034e680d89eaea729c19f450e01.tar.gz
buildroot-novena-11017f081fc5b034e680d89eaea729c19f450e01.zip
pkg-infra: make sure cross compiling is enabled when host == target
When compiling for the same architecture and libc as the host, GNU_TARGET_NAME and GNU_HOST_NAME are equal. configure scripts use these to detect cross-compilation, and will decide that we're doing native compilation. This may trigger running of executables, which fail because of missing libraries in the host environment. To solve this, set the vendor part in GNU_TARGET_NAME to buildroot. This problem exists for instance in xserver_xorg-server on x86_64. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index 64508b283..30a542a65 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -20,7 +20,7 @@ MAKE1:=$(HOSTMAKE) -j1
MAKE:=$(HOSTMAKE) -j$(PARALLEL_JOBS)
# Compute GNU_TARGET_NAME
-GNU_TARGET_NAME=$(ARCH)-unknown-linux-$(LIBC)$(ABI)
+GNU_TARGET_NAME=$(ARCH)-buildroot-linux-$(LIBC)$(ABI)
ifeq ($(BR2_TOOLCHAIN_BUILDROOT)$(BR2_TOOLCHAIN_CTNG_uClibc)$(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
LIBC=uclibc