summaryrefslogtreecommitdiffstats
path: root/package/Makefile.in
diff options
context:
space:
mode:
authorANDY KENNEDY <ANDY.KENNEDY@adtran.com>2012-11-05 06:55:26 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-14 20:40:26 +0100
commit0a4bd19f4a136930c611027942ce43124a81c5cb (patch)
treead2ebd7206ecdaa4137e06c89bcfedafe648cae4 /package/Makefile.in
parente4d89e7f2de5f2586223466a48d8eefba3b0f216 (diff)
downloadbuildroot-novena-0a4bd19f4a136930c611027942ce43124a81c5cb.tar.gz
buildroot-novena-0a4bd19f4a136930c611027942ce43124a81c5cb.zip
Pass --static rather than -static in LDFLAGS when BR2_PREFER_STATIC_LIB
The following changes LDFLAGS from -static to --static if building with BR2_PREFER_STATIC_LIB so that various components actually build statically. Libtool interpret -static as linking statically with libraries that will not be installed to the libdir; you have to pass it -all-static to force static linking. Or, pass --static, which libtool passes on blindly to gcc. gcc and (GNU) ld both interpret --static the same as -static (although this isn't documented). Signed-off-by: Andy Kennedy <andy.kennedy@adtran.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/Makefile.in')
-rw-r--r--package/Makefile.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index cc8f3202c..038bd9c9c 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -319,7 +319,7 @@ endif
ifeq ($(BR2_PREFER_STATIC_LIB),y)
SHARED_STATIC_LIBS_OPTS=--enable-static --disable-shared
-TARGET_LDFLAGS += -static
+TARGET_LDFLAGS += --static
else
SHARED_STATIC_LIBS_OPTS=--enable-static --enable-shared
endif