summaryrefslogtreecommitdiffstats
path: root/make
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2004-07-28 19:26:04 +0000
committerEric Andersen <andersen@codepoet.org>2004-07-28 19:26:04 +0000
commit9647876991d1674fef9de516422f5a54b76dc034 (patch)
tree809384e3c78b4bd78be076861a2688e7b3a6ca6d /make
parentdeb1dbaffca7afc3621c5bfd58d6c6accac5f30a (diff)
downloadbuildroot-novena-9647876991d1674fef9de516422f5a54b76dc034.tar.gz
buildroot-novena-9647876991d1674fef9de516422f5a54b76dc034.zip
Use relative links
Diffstat (limited to 'make')
-rw-r--r--make/ncurses.mk4
-rw-r--r--make/zlib.mk2
2 files changed, 3 insertions, 3 deletions
diff --git a/make/ncurses.mk b/make/ncurses.mk
index d0e401a6b..1768c1e4e 100644
--- a/make/ncurses.mk
+++ b/make/ncurses.mk
@@ -5,7 +5,7 @@
#
#############################################################
# Copyright (C) 2002 by Ken Restivo <ken@246gt.com>
-# $Id: ncurses.mk,v 1.32 2003/11/19 17:17:54 andersen Exp $
+# $Id: ncurses.mk,v 1.33 2004/07/28 19:26:04 andersen Exp $
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU Library General Public License as
@@ -112,7 +112,7 @@ $(TARGET_DIR)/usr/lib/libncurses.a: $(STAGING_DIR)/lib/libncurses.a
(cd $(TARGET_DIR)/usr/lib; ln -fs libncurses.a libtermcap.a)
(cd $(TARGET_DIR)/usr/include; ln -fs ncurses.h curses.h)
rm -f $(TARGET_DIR)/lib/libncurses.so
- (cd $(TARGET_DIR)/usr/lib; ln -fs /lib/libncurses.so.5.2 libncurses.so)
+ (cd $(TARGET_DIR)/usr/lib; ln -fs ../../lib/libncurses.so.5.2 libncurses.so)
-$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libncurses.so.5.2
touch -c $(TARGET_DIR)/usr/lib/libncurses.a
diff --git a/make/zlib.mk b/make/zlib.mk
index 30e6a7c6f..3f23413a2 100644
--- a/make/zlib.mk
+++ b/make/zlib.mk
@@ -54,7 +54,7 @@ $(TARGET_DIR)/usr/lib/libz.a: $(STAGING_DIR)/lib/libz.so.1.1.4
cp -dpf $(STAGING_DIR)/include/zconf.h $(TARGET_DIR)/usr/include/
cp -dpf $(STAGING_DIR)/lib/libz.a $(TARGET_DIR)/usr/lib/
rm -f $(TARGET_DIR)/lib/libz.so
- (cd $(TARGET_DIR)/usr/lib; ln -fs /lib/libz.so.1.1.4 libz.so)
+ (cd $(TARGET_DIR)/usr/lib; ln -fs ../../lib/libz.so.1.1.4 libz.so)
touch -c $(TARGET_DIR)/usr/lib/libz.a
zlib-headers: $(TARGET_DIR)/usr/lib/libz.a