summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-12-21 09:07:45 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-21 09:07:45 +0100
commitef34705087b5841809305afc97188f2eb23a270b (patch)
treeeb81e7f1c6344be595dd92b4ef7773418c4a3f9c /linux
parent309c2f50fa12deeaf7d809e3bdef291a12486b4f (diff)
downloadbuildroot-novena-ef34705087b5841809305afc97188f2eb23a270b.tar.gz
buildroot-novena-ef34705087b5841809305afc97188f2eb23a270b.zip
linux: handle new dtb location since 3.8-rc1
.dtb files are now generated in arch/$ARCH/boot/dts instead of arch/$ARCH/boot, so extend the LINUX_INSTALL_DTB rule to look there as well. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/linux/linux.mk b/linux/linux.mk
index 6586e6815..e852f626f 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -192,7 +192,10 @@ define LINUX_BUILD_DTB
$(TARGET_MAKE_ENV) $(MAKE) $(LINUX_MAKE_FLAGS) -C $(@D) $(KERNEL_DTBS)
endef
define LINUX_INSTALL_DTB
- cp $(addprefix $(KERNEL_ARCH_PATH)/boot/,$(KERNEL_DTBS)) \
+ # dtbs moved from arch/$ARCH/boot to arch/$ARCH/boot/dts since 3.8-rc1
+ cp $(addprefix \
+ $(KERNEL_ARCH_PATH)/boot/$(if $(wildcard \
+ $(addprefix $(KERNEL_ARCH_PATH)/boot/dts/,$(KERNEL_DTBS))),dts/),$(KERNEL_DTBS)) \
$(BINARIES_DIR)/
endef
endif