summaryrefslogtreecommitdiffstats
path: root/linux
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-11-27 09:23:08 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-27 17:05:02 -0800
commit670d60dc919fe6d99224ad1056c426812b38d108 (patch)
tree35fa1701de903c0221c1cffdc42ba5f42445058c /linux
parent3bdbe9abb90de0262832d5d545f239fa41fb0e91 (diff)
downloadbuildroot-novena-670d60dc919fe6d99224ad1056c426812b38d108.tar.gz
buildroot-novena-670d60dc919fe6d99224ad1056c426812b38d108.zip
ocf-linux: tweak kernel patch for newer kernels
Newer kernels had a slight change in the random number API so the OCF patchset requires a slight tweak to build and run properly. Affected kernels are, per series: >=3.0.41, >=3.2.29, >=3.4.9, >=3.5.2 and any newer version. The fix is applied by detecting the API change rather than guessing the kernel version. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'linux')
-rw-r--r--linux/linux-ext-ocf-linux.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/linux/linux-ext-ocf-linux.mk b/linux/linux-ext-ocf-linux.mk
index faf7360e4..1a601d58c 100644
--- a/linux/linux-ext-ocf-linux.mk
+++ b/linux/linux-ext-ocf-linux.mk
@@ -15,6 +15,8 @@ LINUX_DEPENDENCIES += ocf-linux
define OCF_LINUX_PREPARE_KERNEL
support/scripts/apply-patches.sh $(LINUX_DIR) \
$(OCF_LINUX_DIR)/patches/ linux-3.2.1-ocf.patch ; \
+ grep -q __mix_pool_bytes $(LINUX_DIR)/drivers/char/random.c && \
+ $(SED) 's:wordcount\*4:&, NULL:' $(LINUX_DIR)/drivers/char/random.c ; \
cp -rf $(OCF_LINUX_DIR)/ocf $(LINUX_DIR)/crypto/ocf ;
endef