summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorMarkos Chandras <markos.chandras@imgtec.com>2012-11-04 23:44:54 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-21 11:31:33 +0100
commite1ebae700ace80ded99e1a977e28375dc4f7255d (patch)
treebe90ad9725fc47532ee7b81033947f42cdbbab32 /fs
parent8f717d54ba37d289e9e15b2a302cd4d2fe3fb93c (diff)
downloadbuildroot-novena-e1ebae700ace80ded99e1a977e28375dc4f7255d.tar.gz
buildroot-novena-e1ebae700ace80ded99e1a977e28375dc4f7255d.zip
fs/common: Create initial console device
A /dev/console node must be present in rootfs when the Linux kernel boots otherwise the kernel will print the following warning: "Warning: unable to open an initial console" This is because when we use an initramfs the /dev directory is not populated at this point. This can cause problems when a program (e.g ldso with early debugging enabled) opens a standard file descriptor for read/write before these descriptors are actually created by the init process later on. Signed-off-by: Markos Chandras <markos.chandras@imgtec.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs')
-rw-r--r--fs/cpio/cpio.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/fs/cpio/cpio.mk b/fs/cpio/cpio.mk
index aa20b4107..5533322d1 100644
--- a/fs/cpio/cpio.mk
+++ b/fs/cpio/cpio.mk
@@ -21,6 +21,8 @@ define ROOTFS_CPIO_ADD_INIT
fi
endef
+PACKAGES_PERMISSIONS_TABLE += /dev/console c 622 0 0 5 1 - - -$(sep)
+
endif # BR2_ROOTFS_DEVICE_CREATION_STATIC
ROOTFS_CPIO_PRE_GEN_HOOKS += ROOTFS_CPIO_ADD_INIT