summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-03 18:55:43 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-22 21:20:26 +0200
commitc7ee5853a0d54a32aa69a4e4065e6ecdd63c4a4c (patch)
treef9d717b4a18067feacbd367628f4140447bc820e /fs
parentfe1cba690a9afdd661abf0285b08ce95c6347de7 (diff)
downloadbuildroot-novena-c7ee5853a0d54a32aa69a4e4065e6ecdd63c4a4c.tar.gz
buildroot-novena-c7ee5853a0d54a32aa69a4e4065e6ecdd63c4a4c.zip
iso9660: take into account the linux changes
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs')
-rw-r--r--fs/iso9660/Config.in6
-rw-r--r--fs/iso9660/iso9660.mk6
2 files changed, 6 insertions, 6 deletions
diff --git a/fs/iso9660/Config.in b/fs/iso9660/Config.in
index 78305814a..4c00583dc 100644
--- a/fs/iso9660/Config.in
+++ b/fs/iso9660/Config.in
@@ -1,7 +1,7 @@
config BR2_TARGET_ROOTFS_ISO9660
bool "iso image"
- depends on BR2_i386
- depends on !BR2_KERNEL_none
+ depends on (BR2_i386 || BR2_x86_64)
+ depends on BR2_LINUX_KERNEL
select BR2_TARGET_ROOTFS_EXT2
select BR2_TARGET_GRUB
help
@@ -13,4 +13,4 @@ config BR2_TARGET_ROOTFS_ISO9660_BOOT_MENU
default "fs/iso9660/menu.lst"
comment "iso image requires a Linux kernel to be built"
- depends on BR2_i386 && BR2_KERNEL_none
+ depends on (BR2_i386 || BR2_x86_64) && !BR2_LINUX_KERNEL
diff --git a/fs/iso9660/iso9660.mk b/fs/iso9660/iso9660.mk
index 66e2de20b..6f60893a4 100644
--- a/fs/iso9660/iso9660.mk
+++ b/fs/iso9660/iso9660.mk
@@ -15,14 +15,14 @@ ifeq ($(BR2_TARGET_ROOTFS_ISO9660_SQUASH),y)
ISO9660_OPTS+=-U
endif
-$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot $(LINUX_KERNEL) $(BINARIES_DIR)/rootfs.ext2 grub
+$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux26 ext2-root grub
@$(call MESSAGE,"Generating root filesystem image rootfs.iso9660")
mkdir -p $(ISO9660_TARGET_DIR)
mkdir -p $(ISO9660_TARGET_DIR)/boot/grub
cp $(GRUB_DIR)/stage2/stage2_eltorito $(ISO9660_TARGET_DIR)/boot/grub/
cp $(ISO9660_BOOT_MENU) $(ISO9660_TARGET_DIR)/boot/grub/menu.lst
- cp $(LINUX_KERNEL) $(ISO9660_TARGET_DIR)/kernel
- cp $(EXT2_TARGET) $(ISO9660_TARGET_DIR)/initrd
+ cp $(LINUX26_IMAGE_PATH) $(ISO9660_TARGET_DIR)/kernel
+ cp $(BINARIES_DIR)/rootfs.ext2 $(ISO9660_TARGET_DIR)/initrd
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(FAKEROOT_SCRIPT)
touch $(BUILD_DIR)/.fakeroot.00000