summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-09-20 16:19:26 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-20 16:21:20 +0200
commit785fef108ebd940aeabe7e5c2d6d5f54f98e6146 (patch)
treeba65c40a5e609df2fa073e28e5139f1125ca619a /fs
parent3df6b56f53a0dd92752a23e63a0ee5fcacc8ffd0 (diff)
downloadbuildroot-novena-785fef108ebd940aeabe7e5c2d6d5f54f98e6146.tar.gz
buildroot-novena-785fef108ebd940aeabe7e5c2d6d5f54f98e6146.zip
squashfs: bump 4.x, add lzo support
We'll need libattr/xz packages in BR to enable support for those. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs')
-rw-r--r--fs/squashfs/Config.in17
-rw-r--r--fs/squashfs/squashfs.mk7
2 files changed, 23 insertions, 1 deletions
diff --git a/fs/squashfs/Config.in b/fs/squashfs/Config.in
index bcc93b925..20aac085d 100644
--- a/fs/squashfs/Config.in
+++ b/fs/squashfs/Config.in
@@ -19,5 +19,20 @@ config BR2_TARGET_ROOTFS_SQUASHFS3
bool "3.x"
endchoice
-endif
+choice
+ prompt "Compression algorithm"
+ default BR2_TARGET_ROOTFS_SQUASHFS4_GZIP
+ depends on BR2_TARGET_ROOTFS_SQUASHFS4
+ help
+ Select the squashfs compression algorithm to use when
+ generating the filesystem.
+
+config BR2_TARGET_ROOTFS_SQUASHFS4_GZIP
+ bool "gzip"
+
+config BR2_TARGET_ROOTFS_SQUASHFS4_LZO
+ bool "lzo"
+
+endchoice
+endif
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index aae22b6fd..311a3ee1e 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -6,6 +6,13 @@
ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4),y)
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
+
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)
+ROOTFS_SQUASHFS_ARGS += -comp lzo
+else
+ROOTFS_SQUASHFS_ARGS += -comp gzip
+endif
+
else
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3