summaryrefslogtreecommitdiffstats
path: root/fs
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-06-05 17:18:40 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-06-05 21:23:28 +0200
commit3754c51560b5d250b7f0283d1291fea1ec25c55c (patch)
treefcf7d601e1de5b1ecd1b433bf338bb3104356df2 /fs
parent2b42aae78421127a37b7a5e9ae972276dc5c3779 (diff)
downloadbuildroot-novena-3754c51560b5d250b7f0283d1291fea1ec25c55c.tar.gz
buildroot-novena-3754c51560b5d250b7f0283d1291fea1ec25c55c.zip
jffs2: let makedevs create device files
The common filesystem infrastructure in fs/common.mk uses a smart combination of makedevs and fakeroot to create the device files in the target filesystem images without being root. This technique is applied to all filesystem formats that rely on this common infrastructure, and JFFS2 is one of them. Therefore, using the -D option of mkfs.jffs2, which allows to specify a device table, is redundant with the usage of makedevs. And it is worst than redundant: for some reason, -D does not create all device files with the correct major and minor numbers, as reported in bug #1771. For coherence, we just remove the usage of mkfs.jffs2 -D option, and rely on makedevs/fakeroot to create the device files. This commit fixes bug #1771. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs')
-rw-r--r--fs/jffs2/jffs2.mk4
1 files changed, 0 insertions, 4 deletions
diff --git a/fs/jffs2/jffs2.mk b/fs/jffs2/jffs2.mk
index 36be03741..fd5da0c1b 100644
--- a/fs/jffs2/jffs2.mk
+++ b/fs/jffs2/jffs2.mk
@@ -32,10 +32,6 @@ JFFS2_OPTS += -n
SUMTOOL_OPTS += -n
endif
-ifneq ($(ROOTFS_DEVICE_TABLE),)
-JFFS2_OPTS += -D $(ROOTFS_DEVICE_TABLE)
-endif
-
ROOTFS_JFFS2_DEPENDENCIES = host-mtd
ifneq ($(BR2_TARGET_ROOTFS_JFFS2_SUMMARY),)