summaryrefslogtreecommitdiffstats
path: root/fs/tar
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:30:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit0585241505cfaddc9db6ae92739bdfb5ce5f9794 (patch)
tree8fb56f7d4ba91b0384e522c10ed9dbdb77dfe7ec /fs/tar
parent325bfd1cbae03fe286796d3fa7de7c0a3227f7a5 (diff)
downloadbuildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.tar.gz
buildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.zip
Move all filesystem generation code to fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/tar')
-rw-r--r--fs/tar/Config.in47
-rw-r--r--fs/tar/tarroot.mk13
2 files changed, 60 insertions, 0 deletions
diff --git a/fs/tar/Config.in b/fs/tar/Config.in
new file mode 100644
index 000000000..0adca795f
--- /dev/null
+++ b/fs/tar/Config.in
@@ -0,0 +1,47 @@
+config BR2_TARGET_ROOTFS_TAR
+ bool "tar the root filesystem"
+ help
+ Build a tar archive of the root filesystem
+
+choice
+ prompt "Compression method"
+ default BR2_TARGET_ROOTFS_TAR_NONE
+ depends on BR2_TARGET_ROOTFS_TAR
+ help
+ Select compressor for tar archive of the root filesystem
+
+config BR2_TARGET_ROOTFS_TAR_NONE
+ bool "no compression"
+ help
+ Do not compress the tarball.
+
+config BR2_TARGET_ROOTFS_TAR_GZIP
+ bool "gzip"
+ help
+ Do compress the tarball with gzip.
+ Note that you either have to have gzip installed on your host
+ or select to build a gzip for your host. See the packages submenu.
+
+config BR2_TARGET_ROOTFS_TAR_BZIP2
+ bool "bzip2"
+ help
+ Do compress the tarball with bzip2.
+ Note that you either have to have bzip2 installed on your host
+ or select to build a bzip2 for your host. See the packages submenu.
+
+config BR2_TARGET_ROOTFS_TAR_LZMA
+ bool "lzma"
+ help
+ Do compress the tarball with lzma.
+ Note that you either have to have lzma installed on your host
+ or select to build a lzma for your host. See the packages submenu.
+
+endchoice
+
+config BR2_TARGET_ROOTFS_TAR_OPTIONS
+ string "other random options to pass to tar"
+ depends on BR2_TARGET_ROOTFS_TAR
+ default ""
+ help
+ Any other flags you want to pass to tar
+ Refer to tar --help for details
diff --git a/fs/tar/tarroot.mk b/fs/tar/tarroot.mk
new file mode 100644
index 000000000..4d435cb33
--- /dev/null
+++ b/fs/tar/tarroot.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# tar to archive target filesystem
+#
+#############################################################
+
+TAR_OPTS:=$(BR2_TARGET_ROOTFS_TAR_OPTIONS)
+
+define ROOTFS_TAR_CMD
+ tar -c$(TAR_OPTS)f $$@ -C $(TARGET_DIR) .
+endef
+
+$(eval $(call ROOTFS_TARGET,tar))