summaryrefslogtreecommitdiffstats
path: root/fs/squashfs
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 12:15:59 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 12:21:05 +0200
commitb8cee9fb4380a8d58a324d141dcab68a4c3aa29c (patch)
tree9e44711d8aeaac26c1936e2c3882a32e17d60817 /fs/squashfs
parent5ef9fe7e53956ab0a213f64c02366fbfb996bd83 (diff)
downloadbuildroot-novena-b8cee9fb4380a8d58a324d141dcab68a4c3aa29c.tar.gz
buildroot-novena-b8cee9fb4380a8d58a324d141dcab68a4c3aa29c.zip
Add version selection for the SquashFS root filesystem
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/squashfs')
-rw-r--r--fs/squashfs/Config.in19
-rw-r--r--fs/squashfs/squashfs.mk4
2 files changed, 23 insertions, 0 deletions
diff --git a/fs/squashfs/Config.in b/fs/squashfs/Config.in
index 6cc8fcae0..bcc93b925 100644
--- a/fs/squashfs/Config.in
+++ b/fs/squashfs/Config.in
@@ -2,3 +2,22 @@ config BR2_TARGET_ROOTFS_SQUASHFS
bool "squashfs root filesystem"
help
Build a squashfs root filesystem
+
+if BR2_TARGET_ROOTFS_SQUASHFS
+choice
+ prompt "SquashFS version"
+ default BR2_TARGET_ROOTFS_SQUASHFS4
+ help
+ Select the Squash filesystem version to use to generate the
+ root filesystem.
+
+config BR2_TARGET_ROOTFS_SQUASHFS4
+ bool "4.x"
+
+config BR2_TARGET_ROOTFS_SQUASHFS3
+ depends on BR2_DEPRECATED
+ bool "3.x"
+
+endchoice
+endif
+
diff --git a/fs/squashfs/squashfs.mk b/fs/squashfs/squashfs.mk
index d72388ebf..f11ba2090 100644
--- a/fs/squashfs/squashfs.mk
+++ b/fs/squashfs/squashfs.mk
@@ -4,7 +4,11 @@
#
#############################################################
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4),y)
ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
+else
+ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs3
+endif
define ROOTFS_SQUASHFS_CMD
$(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend