summaryrefslogtreecommitdiffstats
path: root/fs/squashfs
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:30:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit0585241505cfaddc9db6ae92739bdfb5ce5f9794 (patch)
tree8fb56f7d4ba91b0384e522c10ed9dbdb77dfe7ec /fs/squashfs
parent325bfd1cbae03fe286796d3fa7de7c0a3227f7a5 (diff)
downloadbuildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.tar.gz
buildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.zip
Move all filesystem generation code to fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/squashfs')
-rw-r--r--fs/squashfs/Config.in4
-rw-r--r--fs/squashfs/squashfsroot.mk13
2 files changed, 17 insertions, 0 deletions
diff --git a/fs/squashfs/Config.in b/fs/squashfs/Config.in
new file mode 100644
index 000000000..6cc8fcae0
--- /dev/null
+++ b/fs/squashfs/Config.in
@@ -0,0 +1,4 @@
+config BR2_TARGET_ROOTFS_SQUASHFS
+ bool "squashfs root filesystem"
+ help
+ Build a squashfs root filesystem
diff --git a/fs/squashfs/squashfsroot.mk b/fs/squashfs/squashfsroot.mk
new file mode 100644
index 000000000..d72388ebf
--- /dev/null
+++ b/fs/squashfs/squashfsroot.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# Build the squashfs root filesystem image
+#
+#############################################################
+
+ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
+
+define ROOTFS_SQUASHFS_CMD
+ $(HOST_DIR)/usr/bin/mksquashfs $(TARGET_DIR) $$@ -noappend
+endef
+
+$(eval $(call ROOTFS_TARGET,squashfs)) \ No newline at end of file