summaryrefslogtreecommitdiffstats
path: root/fs/romfs
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:30:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit0585241505cfaddc9db6ae92739bdfb5ce5f9794 (patch)
tree8fb56f7d4ba91b0384e522c10ed9dbdb77dfe7ec /fs/romfs
parent325bfd1cbae03fe286796d3fa7de7c0a3227f7a5 (diff)
downloadbuildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.tar.gz
buildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.zip
Move all filesystem generation code to fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/romfs')
-rw-r--r--fs/romfs/Config.in5
-rw-r--r--fs/romfs/romfs.mk15
2 files changed, 20 insertions, 0 deletions
diff --git a/fs/romfs/Config.in b/fs/romfs/Config.in
new file mode 100644
index 000000000..7a8c663dd
--- /dev/null
+++ b/fs/romfs/Config.in
@@ -0,0 +1,5 @@
+config BR2_TARGET_ROOTFS_ROMFS
+ bool "romfs root filesystem"
+ help
+ Build a romfs image of the root filesystem.
+
diff --git a/fs/romfs/romfs.mk b/fs/romfs/romfs.mk
new file mode 100644
index 000000000..971947880
--- /dev/null
+++ b/fs/romfs/romfs.mk
@@ -0,0 +1,15 @@
+#############################################################
+#
+# Build the romfs root filesystem image
+#
+#############################################################
+
+ROMFS_TARGET=$(IMAGE).romfs
+
+ROOTFS_ROMFS_DEPENDENCIES = host-genromfs
+
+define ROOTFS_ROMFS_CMD
+ $(HOST_DIR)/usr/bin/genromfs -d $(TARGET_DIR) -f $$@
+endef
+
+$(eval $(call ROOTFS_TARGET,romfs)) \ No newline at end of file