summaryrefslogtreecommitdiffstats
path: root/fs/iso9660
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-11-19 15:01:13 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-19 15:04:49 +0100
commit0a0cb991b715ecc490b77533d49d24424b9d11a2 (patch)
treec7c90beb0b1e8658e2d3a7bcc898f9a35adb4dd5 /fs/iso9660
parentc7af389523ba4134ba88c2e4481a56dab84d3594 (diff)
downloadbuildroot-novena-0a0cb991b715ecc490b77533d49d24424b9d11a2.tar.gz
buildroot-novena-0a0cb991b715ecc490b77533d49d24424b9d11a2.zip
fs: rename make targets to match package/ convention
Use rootfs-* rather than *-root, to match the convention used under package/ and which fits with the ROOTFS_*_ variables. This will also help with the host dependencies. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs/iso9660')
-rw-r--r--fs/iso9660/iso9660.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/fs/iso9660/iso9660.mk b/fs/iso9660/iso9660.mk
index 6f60893a4..2a5288c33 100644
--- a/fs/iso9660/iso9660.mk
+++ b/fs/iso9660/iso9660.mk
@@ -15,7 +15,7 @@ ifeq ($(BR2_TARGET_ROOTFS_ISO9660_SQUASH),y)
ISO9660_OPTS+=-U
endif
-$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux26 ext2-root grub
+$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux26 rootfs-ext2 grub
@$(call MESSAGE,"Generating root filesystem image rootfs.iso9660")
mkdir -p $(ISO9660_TARGET_DIR)
mkdir -p $(ISO9660_TARGET_DIR)/boot/grub
@@ -37,7 +37,7 @@ $(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux26 ext2-root grub
-@rm -f $(FAKEROOT_SCRIPT)
-@rm -rf $(ISO9660_TARGET_DIR)
-iso9660-root: $(BINARIES_DIR)/rootfs.iso9660
+rootfs-iso9660: $(BINARIES_DIR)/rootfs.iso9660
#############################################################
#
@@ -45,5 +45,5 @@ iso9660-root: $(BINARIES_DIR)/rootfs.iso9660
#
#############################################################
ifeq ($(BR2_TARGET_ROOTFS_ISO9660),y)
-TARGETS+=iso9660-root
+TARGETS+=rootfs-iso9660
endif