summaryrefslogtreecommitdiffstats
path: root/fs/initramfs
diff options
context:
space:
mode:
authorWill Wagner <will_wagner@carallon.com>2010-04-19 15:34:49 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-04-20 00:02:36 +0200
commit102ca91d741d0d271d96170df491bec7fdb7880a (patch)
treed8838764cb540fb759eb4bc77cd58306ea485eb9 /fs/initramfs
parenta726691a00aefc21e0052e6d27ad45f5ec06f79b (diff)
downloadbuildroot-novena-102ca91d741d0d271d96170df491bec7fdb7880a.tar.gz
buildroot-novena-102ca91d741d0d271d96170df491bec7fdb7880a.zip
Repair initramfs dependancies after move to fs
The restructure for building root filesystems changed the target name for the initramfs file, to build the file the trget is now initramfs-root but the generated file is rootfs.initramfs Signed-off-by: Will Wagner <will_wagner@carallon.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs/initramfs')
-rw-r--r--fs/initramfs/initramfs.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/fs/initramfs/initramfs.mk b/fs/initramfs/initramfs.mk
index 4a205d1ce..9aaf1b04a 100644
--- a/fs/initramfs/initramfs.mk
+++ b/fs/initramfs/initramfs.mk
@@ -6,6 +6,12 @@
#
#############################################################
+ifeq ($(BR2_TARGET_ROOTFS_INITRAMFS),y)
+INITRAMFS_TARGET:=initramfs-root
+else
+INITRAMFS_TARGET:= #nothing
+endif
+
define ROOTFS_INITRAMFS_INIT_SYMLINK
rm -f $(TARGET_DIR)/init
ln -s sbin/init $(TARGET_DIR)/init