summaryrefslogtreecommitdiffstats
path: root/fs/ext2
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-01-20 15:03:13 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-20 20:53:29 +0100
commit847895d29524d81b64afb059b8649a77802a469b (patch)
treea13cce1a338234460fcc992d5e56472013be35ca /fs/ext2
parent26f16d0fcf778562966dfa82b5a768007266d716 (diff)
downloadbuildroot-novena-847895d29524d81b64afb059b8649a77802a469b.tar.gz
buildroot-novena-847895d29524d81b64afb059b8649a77802a469b.zip
fs/common.mk: delay evaluation of variables
This makes things easier to understand and more consistent with the pkg-infra. For example, it removes the need for '$$@' in the CMD variables of fs/*/*.mk. It also makes it possible to update the variables later, e.g. in the package override file. It also makes sure that the date will be recorded correctly in Yann E. Morin's patch that logs the MESSAGE macros to a file. The fs/*/*.mk must be updated as well because the '$@' shouldn't be quoted anymore in the CMD variables or the hooks. The $(eval ...) for the dependencies is redundant, because the $(ROOTFS_TARGET) variable is already eval'd. Note that it is only redundant if the evaluation of the uses of the variable is also delayed. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs/ext2')
-rw-r--r--fs/ext2/ext2.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/ext2/ext2.mk b/fs/ext2/ext2.mk
index cc8da0e4d..7b71592d9 100644
--- a/fs/ext2/ext2.mk
+++ b/fs/ext2/ext2.mk
@@ -21,7 +21,7 @@ endif
ROOTFS_EXT2_DEPENDENCIES = host-genext2fs
define ROOTFS_EXT2_CMD
- PATH=$(TARGET_PATH) fs/ext2/genext2fs.sh -d $(TARGET_DIR) $(EXT2_OPTS) $$@
+ PATH=$(TARGET_PATH) fs/ext2/genext2fs.sh -d $(TARGET_DIR) $(EXT2_OPTS) $@
endef
$(eval $(call ROOTFS_TARGET,ext2))