summaryrefslogtreecommitdiffstats
path: root/fs/common.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-17 03:26:16 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-17 04:36:23 +0200
commit64ec20e6c019e329bf6923fbf330b86b3cfad524 (patch)
tree82c654bd483db0e92dc55537f9bf9aa614a16559 /fs/common.mk
parente5da1b85209d31044af7be529dfd355b836b4fad (diff)
downloadbuildroot-novena-64ec20e6c019e329bf6923fbf330b86b3cfad524.tar.gz
buildroot-novena-64ec20e6c019e329bf6923fbf330b86b3cfad524.zip
fs: change the way the device table is configured
Until now, the location of the device table was specified by a variable in board Makefiles. Unfortunately, this variable is not accessible from fs/common.mk, since the target/ code is included *after* fs/common.mk. Anyway, the general idea is to move away from these boards Makefile, and provide configuration option for things like the device table location. Therefore, this patch adds a BR2_ROOTFS_DEVICE_TABLE option which allows to specify which device table should be used. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/common.mk')
-rw-r--r--fs/common.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/fs/common.mk b/fs/common.mk
index fa6afd94d..cc94eb4ef 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -28,6 +28,7 @@
# macro will automatically generate a compressed filesystem image.
FAKEROOT_SCRIPT = $(BUILD_DIR)/_fakeroot.fs
+ROOTFS_DEVICE_TABLE = $(call qstrip,$(BR2_ROOTFS_DEVICE_TABLE))
define ROOTFS_TARGET_INTERNAL
@@ -38,8 +39,8 @@ $(BINARIES_DIR)/rootfs.$(1): $(ROOTFS_$(2)_DEPENDENCIES) host-fakeroot makedevs
touch $(BUILD_DIR)/.fakeroot.00000
cat $(BUILD_DIR)/.fakeroot* > $(FAKEROOT_SCRIPT)
echo "chown -R 0:0 $(TARGET_DIR)" >> $(FAKEROOT_SCRIPT)
-ifneq ($(TARGET_DEVICE_TABLE),)
- echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" >> $(FAKEROOT_SCRIPT)
+ifneq ($(ROOTFS_DEVICE_TABLE),)
+ echo "$(HOST_DIR)/usr/bin/makedevs -d $(ROOTFS_DEVICE_TABLE) $(TARGET_DIR)" >> $(FAKEROOT_SCRIPT)
endif
echo "$(ROOTFS_$(2)_CMD)" >> $(FAKEROOT_SCRIPT)
chmod a+x $(FAKEROOT_SCRIPT)