summaryrefslogtreecommitdiffstats
path: root/fs/common.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-01-22 01:03:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-24 22:18:13 +0200
commit5419651bfa38355b2b2015868811197ef18577d0 (patch)
treea5b37dc69ab1e8db71b95c3b4d639bf044736409 /fs/common.mk
parent5b935275ec540400b417bd28649e510b4358416a (diff)
downloadbuildroot-novena-5419651bfa38355b2b2015868811197ef18577d0.tar.gz
buildroot-novena-5419651bfa38355b2b2015868811197ef18577d0.zip
fs/common: add support for LZO and XZ compression methods
Add support for LZO and XZ compression methods to cpio, ext2, tar and ubifs filesystem targets. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs/common.mk')
-rw-r--r--fs/common.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/fs/common.mk b/fs/common.mk
index a0b7b3909..c6f67d831 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -39,7 +39,7 @@ ROOTFS_DEVICE_TABLES = $(call qstrip,$(BR2_ROOTFS_DEVICE_TABLE) \
define ROOTFS_TARGET_INTERNAL
# extra deps
-ROOTFS_$(2)_DEPENDENCIES += host-fakeroot host-makedevs $$(if $$(BR2_TARGET_ROOTFS_$(2)_LZMA),host-lzma)
+ROOTFS_$(2)_DEPENDENCIES += host-fakeroot host-makedevs $$(if $$(BR2_TARGET_ROOTFS_$(2)_LZMA),host-lzma) $$(if $$(BR2_TARGET_ROOTFS_$(2)_LZO),host-lzop) $$(if $$(BR2_TARGET_ROOTFS_$(2)_XZ),host-xz)
$$(BINARIES_DIR)/rootfs.$(1): $$(ROOTFS_$(2)_DEPENDENCIES)
@$$(call MESSAGE,"Generating root filesystem image rootfs.$(1)")
@@ -70,6 +70,12 @@ endif
ifeq ($$(BR2_TARGET_ROOTFS_$(2)_LZMA),y)
$$(LZMA) -9 -c $$@ > $$@.lzma
endif
+ifeq ($$(BR2_TARGET_ROOTFS_$(2)_LZO),y)
+ $$(LZOP) -9 -c $$@ > $$@.lzo
+endif
+ifeq ($$(BR2_TARGET_ROOTFS_$(2)_XZ),y)
+ $(XZ) -9 -C crc32 -c $$@ > $$@.xz
+endif
rootfs-$(1)-show-depends:
@echo $$(ROOTFS_$(2)_DEPENDENCIES)