summaryrefslogtreecommitdiffstats
path: root/fs/common.mk
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2010-11-19 15:01:13 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-19 15:04:49 +0100
commit0a0cb991b715ecc490b77533d49d24424b9d11a2 (patch)
treec7c90beb0b1e8658e2d3a7bcc898f9a35adb4dd5 /fs/common.mk
parentc7af389523ba4134ba88c2e4481a56dab84d3594 (diff)
downloadbuildroot-novena-0a0cb991b715ecc490b77533d49d24424b9d11a2.tar.gz
buildroot-novena-0a0cb991b715ecc490b77533d49d24424b9d11a2.zip
fs: rename make targets to match package/ convention
Use rootfs-* rather than *-root, to match the convention used under package/ and which fits with the ROOTFS_*_ variables. This will also help with the host dependencies. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs/common.mk')
-rw-r--r--fs/common.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/fs/common.mk b/fs/common.mk
index 74e9ce060..f9dababb2 100644
--- a/fs/common.mk
+++ b/fs/common.mk
@@ -61,13 +61,13 @@ ifeq ($$(BR2_TARGET_ROOTFS_$(2)_LZMA),y)
$(LZMA) -9 -c $$@ > $$@.lzma
endif
-$(1)-root-show-depends:
+rootfs-$(1)-show-depends:
@echo $(ROOTFS_$(2)_DEPENDENCIES) host-fakeroot host-makedevs $(if $(BR2_TARGET_ROOTFS_$(2)_LZMA),host-lzma)
-$(1)-root: $(BINARIES_DIR)/rootfs.$(1) $(ROOTFS_$(2)_POST_TARGETS)
+rootfs-$(1): $(BINARIES_DIR)/rootfs.$(1) $(ROOTFS_$(2)_POST_TARGETS)
ifeq ($$(BR2_TARGET_ROOTFS_$(2)),y)
-TARGETS += $(1)-root
+TARGETS += rootfs-$(1)
endif
endef