summaryrefslogtreecommitdiffstats
path: root/fs/cloop
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-01-20 15:03:13 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-20 20:53:29 +0100
commit847895d29524d81b64afb059b8649a77802a469b (patch)
treea13cce1a338234460fcc992d5e56472013be35ca /fs/cloop
parent26f16d0fcf778562966dfa82b5a768007266d716 (diff)
downloadbuildroot-novena-847895d29524d81b64afb059b8649a77802a469b.tar.gz
buildroot-novena-847895d29524d81b64afb059b8649a77802a469b.zip
fs/common.mk: delay evaluation of variables
This makes things easier to understand and more consistent with the pkg-infra. For example, it removes the need for '$$@' in the CMD variables of fs/*/*.mk. It also makes it possible to update the variables later, e.g. in the package override file. It also makes sure that the date will be recorded correctly in Yann E. Morin's patch that logs the MESSAGE macros to a file. The fs/*/*.mk must be updated as well because the '$@' shouldn't be quoted anymore in the CMD variables or the hooks. The $(eval ...) for the dependencies is redundant, because the $(ROOTFS_TARGET) variable is already eval'd. Note that it is only redundant if the evaluation of the uses of the variable is also delayed. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'fs/cloop')
-rw-r--r--fs/cloop/cloop.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/fs/cloop/cloop.mk b/fs/cloop/cloop.mk
index c1d6abb80..c91868407 100644
--- a/fs/cloop/cloop.mk
+++ b/fs/cloop/cloop.mk
@@ -7,7 +7,7 @@
ROOTFS_CLOOP_DEPENDENCIES = host-cloop host-cdrkit
define ROOTFS_CLOOP_CMD
- $(HOST_DIR)/usr/bin/genisoimage -r $(TARGET_DIR) | $(HOST_DIR)/usr/bin/create_compressed_fs - 65536 > $$@
+ $(HOST_DIR)/usr/bin/genisoimage -r $(TARGET_DIR) | $(HOST_DIR)/usr/bin/create_compressed_fs - 65536 > $@
endef
$(eval $(call ROOTFS_TARGET,cloop)) \ No newline at end of file