summaryrefslogtreecommitdiffstats
path: root/docs
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2012-11-11 03:14:57 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-15 23:59:54 +0100
commitbaa838e39251d298dbb4c031638b83a1b28f6881 (patch)
treea37d71dbdc197847f81c649ab20c63164f3f130b /docs
parent6c61000c3a8ef46a0ded12476b005ae220b90371 (diff)
downloadbuildroot-novena-baa838e39251d298dbb4c031638b83a1b28f6881.tar.gz
buildroot-novena-baa838e39251d298dbb4c031638b83a1b28f6881.zip
manual: add adding-package-tips.txt
Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'docs')
-rw-r--r--docs/manual/adding-packages-tips.txt54
-rw-r--r--docs/manual/adding-packages.txt2
2 files changed, 56 insertions, 0 deletions
diff --git a/docs/manual/adding-packages-tips.txt b/docs/manual/adding-packages-tips.txt
new file mode 100644
index 000000000..acc73d311
--- /dev/null
+++ b/docs/manual/adding-packages-tips.txt
@@ -0,0 +1,54 @@
+// -*- mode:doc; -*-
+
+Tips and tricks
+~~~~~~~~~~~~~~~
+
+[[package-name-variable-relation]]
+Package name, config entry name and makefile variable relationship
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+
+In Buildroot, there are some relation between:
+
+* the _package name_, which is the package directory name (and the
+ name of the +*.mk+ file);
+
+* the config entry name that is declared in the +Config.in+ file;
+
+* the makefile variable prefix.
+
+Thus, it is mandatory to keep consistency between all this stuff,
+matching the following rules:
+
+* the _make_ target name will be the _package name_ itself (e.g.:
+ +foo-bar_boo+);
+
+* the config entry is the upper case _package name_ with `.` and `-`
+ characters substituted with `_`, prefixed with +BR2_PACKAGE_+ (e.g.:
+ +BR2_PACKAGE_FOO_BAR_BOO+);
+
+* the +*.mk+ file variable prefix is the upper case _package name_
+ `.` and `-` characters substituted with `_` (e.g.:
+ +FOO_BAR_BOO_VERSION+).
+
+
+[[github-download-url]]
+How to add package from github
+^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+
+If the package has no release version, or its version cannot be
+identified using tag, then the sha1 of the particular commit should be
+used to identify the version (the first 7 characters of the sha1 are
+enough):
+
+------------------------
+FOO_VERSION = 1234567
+FOO_SITE = http://github.com/<user>/<package>/tarball/<branch>
+------------------------
+
+If the package version matches a tag, then this tag should be used to
+identify the version:
+
+------------------------
+FOO_VERSION = v1.0
+FOO_SITE = http://github.com/<user>/<package>/tarball/$(FOO_VERSION)
+------------------------
diff --git a/docs/manual/adding-packages.txt b/docs/manual/adding-packages.txt
index 8221c855a..b909d47a8 100644
--- a/docs/manual/adding-packages.txt
+++ b/docs/manual/adding-packages.txt
@@ -19,4 +19,6 @@ include::adding-packages-cmake.txt[]
include::adding-packages-gettext.txt[]
+include::adding-packages-tips.txt[]
+
include::adding-packages-conclusion.txt[]